Jump to content

1.7.7 my little CPU monster


Recommended Posts

I finally decided to update to 1.7.7 today and every since I did my utorrent has been using 80-100% cpu. If have it running normally I can hardly do anything on my computer. If I GREATLY reduce my download speed it will stay around 50% CPU but I still can't watch a movie or anything because it will cause stuttering. The only way to get normal usage from my computer is if I pause ALL torrents or exit the program. I can't even leave 1 torrent going at 100% speed. I haven't changed a single setting since I updated and it worked fine before the update.

I tried Process Explorer and the thread with the start address uTorrent.exe+0x1751b seems to be the cause.

Here's a copy of the stack for that thread (TID 3816):


















Link to comment
Share on other sites

my torrents always go to the same location. i don't move them until they are finished seeding. if i need them somewhere else i copy them and then delete them after they are done seeding. nothing is checking when the issue occurs.


It appears the issue does return over time. After a few hours utorrent starts eating up all my cpu. The only way I have found to temporarily fix it is by restarting. If exit utorrent it's process will remain for up to 2 minutes and will spike HUGE on the cpu basically locking my mouse up even and then finally goes away. As soon as I relaunch utorrent it very quickly goes back up to 100% cpu usage. If i log out and log back in and launch utorrent it does the same thing. I have to restart to make the issue go away for a few hours.

Link to comment
Share on other sites

UMDA is on for all drives.

i believe it was my net.max_halfopen setting. i reset it 8 and have not had the problem all day. i assumed i was patched because the tweak site i was looking at mentioned a windows update that basically patched the system for you. i patched my system and set it back to 50 and just waiting to see what happens. i still don't think this is it because the settings i'm using worked for several days. the issue started right after i updated.

I don't use software firewalls. And what device's drivers are you thinking are bad?

Link to comment
Share on other sites


i have the same problem i installed 1.8 alpha and my cpu went nuts it kept hitting 100% then it crashed my laptop so after restart i installed 1.7.7 but i still have the same problem it goes from using 10-11% cpu to 90%+ then back down and speeds in between which of course makes it impossible to do anything else. i m runnin intel core 2 duo 2ghz and i have eset smart security installed. os = vista home premium

thanks in advance

Link to comment
Share on other sites


I have the exact same problem. After downloading some hours, the CPU usage increases extremely, and I can no longer exit uTorrent, it gets stuck in the task manager, or sometimes it just won't exit.

Can somebody help me? How do I update my drivers? And which drivers?

How do I "make sure that your drive controller is set to UDMA for all drives?"

And I use Zone Alarm Free and Avira Antivirus.

Any solutions?

Link to comment
Share on other sites

Start > Run > devmgmt.msc

Look at the primary and secondary IDE ATA/ATAPI controllers' properties to see if any of the connected devices' current transfer mode are PIO.

While you're at it...

a) get HijackThis from trendsecure.com, run it, view the log, and post the contents here

B) get Process Explorer from sysinternals.com, run it, Ctrl+D (to show the lower DLL pane), select the µTorrent process from the list, Ctrl+S (and save the list somewhere you'll find easily -- like the Desktop) , then post the contents of the saved process list in the .txt file here

Link to comment
Share on other sites

Thx for det quick replies. Before I start, I want to tell, that my uTorrent isn't using so much CPU at this moment. It starts doing that after a couple of hours, so I don't know how it effects the logs from Hijackthis etc.

And by the way, I've just uninstalled ZoneAlarm. Don't know the effects of this either.

I looked at devmgmt

and I don't know if I've read it correctly, but it says at the 2 IDE ATA/ATAPI controllers I've got:

"Activate DMA" is checked on both

and "Ultra DMA 5"

Link to comment
Share on other sites

CryptoAPI.dll CryptoAPI HiTRUST 2.02.0000.0034

keyManager.dll keyManager HiTRSUT 2.02.0000.0018

ShowErrMsg.dll ShowErrMsg 2.05.3024.0022

sysenv.dll System share library HiTRUST 2.05.3021.0108

SysHook.dll SysHook DLL 0.09.0007.0003

I don't know what these are doing being hooked into uTorrent's process, but they are extremely suspect for doing so.

Link to comment
Share on other sites

I think current transfer mode is Ultra DMA 5, cause my Vista isn't in English, and the nearest I could find said Ultra DMA 5. Actually it says (translated:) "current condition" -> "ultra dma 5".

I have uninstalled Zone Alarm, and temporarily there seems to be no problems, even though I haven't tried to exit uTorrent. Let's see how it will get tomorrow. What alternative firewall do you reccomend me? I have Vista.

Link to comment
Share on other sites

Okay thank you very much Ultima. I'll try it.

By the way, after uninstalling Zone Alarm, I don't have any CPU troubles with my uTorrent. So I think you should add ZoneAlarm to the list of apps, thay may disturb uTorrent.

EDIT: I meant, after UNinstalling ZoneAlarm.. Sorry.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...