Archived

This topic is now archived and is closed to further replies.

mofle

Add-url problem

Recommended Posts

Yes, and last I checked, it still works.

@mofle: That it outputs an empty dictionary (well, it's no longer empty, since it returns the build number now) doesn't mean it's not working. I just tried the command, and it worked perfectly. A bit of patience would help.

Share this post


Link to post
Share on other sites

:( COOL! Works for me http://localhost:12358/gui/?action=add-url&s=http://www.mininova.org/get/1297677

Edit: The GUI log message though is... odd

[18:50:41] HTTP: IP ::1: GET /gui/?action=add-url&s=http://www.mininova.org/get/1297677

the full address I used was admin:1@localhost:12358 so obviously something isn't interpreted right, right?

I guess it has to do with localhost DNS ... and the fact I don't have a real ipv6 address even through teredo, I dunno

Both my LAN IP and localhost show the correct IP

[21:13:47] HTTP: IP 127.0.0.1: GET /gui/?action=add-url&s=http://www.mininova.org/get/1297678

[21:13:45] HTTP: IP 192.168.0.101: GET /gui/?action=add-url&s=http://www.mininova.org/get/1297679

Share this post


Link to post
Share on other sites

Right... I still haven't gotten any wiser on {"":""} problem though...

Anyone have a solution for this?

(other than waiting for µTorrrent 1.8 and the new WebUI to be released)

Share this post


Link to post
Share on other sites

Then it wasn't a proper add-url. Either it wasn't encoded properly or the torrent didn't exist.

As I said before. No matter if the torrent was added or not the page always returns {"":""}. There is no error reporting for ?action=add-url.

Share this post


Link to post
Share on other sites

Shouldn't there be some error reporting returned from add-url though?

@mofle, the link you pasted above looks fine to me. Have you checked the logging in uTorrent to see if the GET was received?

Share this post


Link to post
Share on other sites

No, because if the server is slow, and you have to wait for µTorrent to spit an error back (because it's waiting for the server to respond), the webui might think it's timed out instead. There's no reason to time the UI out just because of an external problem.

Share this post


Link to post
Share on other sites

Is there a LIMIT for the add-url

I just noticed you can add a cookie also through the WebUI interface (futzing with the multilang) ... but the request is truncated. it works from the GUI.

GET /gui/?action=add-url&s=http%3A//www.demonoid.com/files/download/HTTP/1425221/1854827/:COOKIE:uid=185

whereas the cookie is 134 characters long.

If it's helpful, the urls returned in the logger tab are always 131 characters: the last 101 of which are the URL

Share this post


Link to post
Share on other sites