Jump to content

Multi-user Webui-Shell

Lord Alderaan

Recommended Posts

  • Replies 540
  • Created
  • Last Reply

Thanks, Also a friend tried placing the site in an iframe and comes with the same error despite it working normally - don't know if that helps or not.

Also I have one small feature request: can you allow the login authentication to be done via basic authentication (the same as what webUI uses), as then this will allow all apps that use utorrent API to use this multi user interference without any modification on their side. some apps will work if they are attached to a web browser and can see if the user has already logged in.

Link to comment
Share on other sites

Hello! :)

Just installed it! Some points:

I installed it on my DreamHost account, where I have a custom PHP5 install --where I can't use new RewriteRule's without ask them to reboot the server (strange, because AddHandler worked instantly). I then renamed /webui_shell/ folder to /whatever/ (which is the name I want to use -- not /gui/) and configured config.php with same value. Worked! =D

Conclusion: rewrite can be described as optional since you made it no absolute path dependant (no direct references to /home/username/website/webui_shell folder).

Problem I'm facing:

No "layout" downloaded. See:

http://lord123:123@www.mundialnet.info/seedbox/ -- the seedbox admin

http://lord234:234@www.mundialnet.info/seedbox/ -- restricted (guest)


Link to comment
Share on other sites

It is not optional. Without the rewrite you only get the index.html file and none of the other webui files.

For example:

The reason of the rewrite is so that a link like http://www.mundialnet.info/gui/images/toolbar.png leads to the webuishell at http://www.mundialnet.info/webui_shell/index.php?shell_file=images/toolbar.png and then the webui_shell then gets that file from http://utorrentip:utorrentport/images/toolbar.png and returns it (with not allowed buttons filtered from it).

http://www.mundialnet.info/webui_shell/images/toolbar.png returns 404 because it does not exist. And if you'd create the file (extracted from the webui.zip) it would be there but it wouldn't be filtered.

But maybe there is a way to do it without the rewrite but that is gonna be put down low on the todo list because it would be more of a nuisance to keep updated might remove or make certain features complicated and the only purpose it would serve is seedbox users without apache admin access.

Link to comment
Share on other sites

I got it.

I will ask DreamHost if my custom PHP setup that I have on my accounts is the reason for Rewrite not work. If there's no way to get it functional there, I will use my seedbox server -- I just avoided it from start, because sometimes we need to upgrade server, which would require a new setup off webui shell.

Thanks, Lord Alderaan!

-- edit


none of provided rewrite rules is working for me (tried yours and SilentStriker)

I'm still seeing the /gui/ directory listing... :(

Tried on a fresh system (just installed apache + php 5 and required modules, all loaded!)

May we chat through IM or PMs?

Link to comment
Share on other sites

after installation it worked fine for some time: users saw only their own downloads. But after that something happened and all the downloads became visible for all users. Flag "Show_All_Torrents" is set to "0" for all users. There are something about 60 downloads in list - how to split them by users again?

Link to comment
Share on other sites

  • 3 weeks later...

Ok I just released 0.3

To upgrade from 0.2 download the new rar and extract the files in it. Overwrite all the old webui_shell files with the new ones except for your config.php. Login to the admin panel and the webui will update itself (required).

To install afresh follow the readme.

The major changes are also listed in the OP.

I had to push some tasks to the next release or this release would have taken even longer.

Eagerly awaiting bugs and new suggestions.

Link to comment
Share on other sites

I've just upgraded from 0.23 to 0.3 the way you described, Alderaan.

What worked great with the old version, the new one is not.

My browsers (IE7 + FF3) tell me, they stop loading the page because it leads to an infinite redirection loop.

Then I replaced the files one by one. Index.php is that one causing this error.

The webui_shell is running on IIS6 with latest PHP5. I can confirm every time, that it is the new Index.php by just replacing it with the old (0.23) version.

Maybe you can help with that.

Many thanks so far.

Link to comment
Share on other sites

Thanks for the fast reply.

This is the output:


I just accidently misspelled the url (with the 0.30 index.php in use). I typed http://server/gui/, - yes, a comma after the 'gui/' and the login-screen opened. I didn't try to login. Maybe that helps a bit.

Update: Ok, after trying to login with the misspelled url, FF once again gives me the same error.

Link to comment
Share on other sites

That looks promising. I think it works. In IE7 it's ok. Have to try in FF3. Thank you very much for your fast help!

Update: Works flawlessly on IE7 and FF3. Thank you!

Another question:

Is there a chance to get rid of the /gui ? As I am running this app in a seperate (sub)domain I don't need the /gui to distinguish between several apps on that domain.

Link to comment
Share on other sites


I have a similar problem as splinter98 had. The CSS doesnt seem to work when using webui shell (webui alone is fine) thus there is no style on the page.

I can give a test login to show or screenshot.

Btw that fix on the index (few posts before) fixed my other problem, i had loop in apache and lighttpd too.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...