Archived

This topic is now archived and is closed to further replies.

dlzmu5

Very slow download speed, even after changes from Speed Issues guide

Recommended Posts

Hi there,

I would like to ask You for help with setting up my Utorrent, as it should run...

First time when i installed Utorrent i just left settings in default, but with the most of torrents i had download speed about 20kb/s (on a 6mbit line), but few of them worked fine. On this forum i found lots of topics with some clues to increase download speed but none of them worked. Here i have got list of things that i have done to have download speed on proper level (most of them are just clues from that topic:

1.I looked up Setup Guide few times to make sure i have done all steps properly (checked port forwarding etc.)

2.I have read FAQ to find some more information about Utorrent

3.Made speed test (CTRL+G) few times to make sure i have set proper settings

4.Updated Utorrent to latest stable version (2.0.3)

5.Tried to set up Switeck's conservative settings

6.Tried lowering net.max_halfopen and bt.connect_speed, disabling UPnP, DHT etc.

7.Checked version of AMD processor drivers due to information found in this topic

8.Made Glasnost test and few more tests

One and only thing that i have not done is modifing TCPIP.sys file due to that i do not have some ultra fast line, so i can not handle to much connections at once.

Following to speed issues guide topic i am giving You all needed information:

The state/value of all of the options you were recommended to change up above.

UPnP ports mapping = disabled

DHT = disabled

Protocol Encryption = enabled

bt.connect_speed = 4

bt.tcp_rate _control = false

bt.transp_disposition = 21

net.max_halfopen = 4

After changing all of this torrents were downloading even worse (2kb/s)...Utorrent status bar told me that my port is not opened, so i checked that on some website and saw the same. I decided to change settings to defaults and everything got back as before (download approx 20kb/s and port opened). Now i really do not know what to do... But let's go on with information:

Color of the network status light in µTorrent's status bar (at the bottom of the µTorrent main window)

Before changes = green (port opened)

After changes = orange (port closed but downloading still possible)

What the port checker from the Speed Guide writes

Both UDP and TCP ports are filtered 2q0u0za.png

What the Speed Guide shows your settings to be (press Ctrl+G in µTorrent)

fnu7iw.png

What you have net.max_halfopen set to (Preferences > Advanced in µTorrent), and if you ever modified TCPIP.sys, what you patched the limit to

net.max_halfopen = 8 (TCPIP.sys never modified)

Operating system installed (Windows XP, 2000, ME, 98, 95, NT? Something else?)

Windows XP with Service Pack 3

Security software installed (firewall, antivirus, antispyware, antiadware)

Antivirus = Avast! Free Antivirus

Firewall = hardware (router with NAT)

Antispyware = Malwarebytes' Anti-Malware (free version, no live-security)

Exact router model(s), and exact modem model

Router = TP-Link TD-W8910G

Modem = Built-in with router

ISP (Internet Service Provider) being used

Neostrada Plus (Telekomunikacja Polska)

Connection type (DSL, cable, dial-up), and the results obtained from the speed test (when running the Speed Guide), for both download AND upload.

Source: http://www.speedguide.net/speedtest/results.php?test=3011929

« SpeedGuide.net Speed Test Results »

5264 kbps down (~5.26 Mbps, 643 KB/s)↓

536 kbps up (~0.54 Mbps, 65 KB/s)↑

3072 KB downloaded in 4.781 seconds

1024 KB uploaded in 15.645 seconds

Tested on: 2010.08.25 13:11 EDT

Tested from: dagobah.biz

Test Link: http://www.speedguide.net/speedtest/results.php?test=3011929

Latency: 155ms

Provider: neoplus.adsl.tpnet.pl

Location: Warszawa, PL

OK, that's all i have for You. If it is not very big problem, please try to help me with solving this problem.

Best regards, dlzmu5.

Share this post


Link to post
Share on other sites

Im having the same problem as you,my net speed starts okay,around 40kB/s (my net speed is 512 kBs) and then it just drops after a few minutes to around 15kB/s and its very random,averaging around 15kBs. Ive looked around here alot,tinkered with a lot of the settings and nothing works.

So i think its the same problem as mine ; ISP throttling...

Share this post


Link to post
Share on other sites

Did Glasnost report any oddities?

Know anyone else on the same ISP? If so, does uTorrent run ok for them?

Can you test your network/router/computer or at least uTorrent settings with another ISP?

If it's ISP throttling/disruption, there's limits as to what can be done. Try the 3rd link in my signature?

Share this post


Link to post
Share on other sites

I have just made Glasnost test on two computers: mine and my friend's who has got 512kb line from same ISP. Glasnost have not reported any throttling on both of lines. But when i tried to download torrent on my friend's PC same as mine problem has occured. He has never used Bittorrent protocol before and his download speed was approx 10kb/s.

Here i am giving You link with detailed Glasnost test infromation:

http://loki10.mpi-sws.mpg.de//bb//glasnost.php?protocol1=BitTorrent&protocol2=control%20flow&port=6881&port2=52364&dir=0;1&flow0=225;226;232&flow1=229;229;228&flow2=229;229;229&flow3=227;229;226&flow4=4446;4657;4532&flow5=4496;4049;4539&flow6=4164;4469;4739&flow7=4390;4405;4421&details=yes

Best regards, dlzmu5

Share this post


Link to post
Share on other sites

Glasnost results can be faked, as there are ISPs that are known to be awful for BitTorrent due to disrupting/throttling which perfectly pass Glasnost tests.

Your Glasnost tests look ok, but the upload (~229 kilobits/sec) and even the download max (~4400 kilobits/sec) seems low compared to the speeds you reported earlier:

5264 kbps down (~5.26 Mbps, 643 KB/s)↓

536 kbps up (~0.54 Mbps, 65 KB/s)↑

Share this post


Link to post
Share on other sites

Thanks for that information, i did not know that there is a way around Glasnost, and now i released that something is wrong if i get low download speed while testing only Bittorrent protocol (not entire connection with Internet). I will try to find out some way around that throttling issue as You told me to do in your previous post.

Best regards, dlzmu5

Share this post


Link to post
Share on other sites

OK, i have just finished applying changes mentioned in ISP throttling topic, but these do not work.

What i have done is:

1.Disabled UPnP, NAT-PMP, LPD, DHT (both kinds)...

...but after that change Setup Guide has shown me something like this:

efhp2h.png

...but downloading was still possible

2.Reduced global and per-torrent max connections to 10

3.Set upload slots per torrent to 2

4.Set total upload speed to 8 KB/sec

5.Set total download speed to 500kb/s (~75% of my max connection speed)

6.Lowered bt.connect_speed to 1

7.Lower net.max_halfopen to 3

8.Set Encryption to Forced and disabled Incoming Legacy Connections.

9.Set net.bind_ip and net.outgoing_ip to my LAN ip address

After all of these changes download speed... lowered to approx 0,5kB/s. For now i do not know any other way to do anything with my problem. Do You think changing ISP is the only way?

Best regards, dlzmu5

Share this post


Link to post
Share on other sites

If you do manual port forwarding, NAT-PMP and UPnP should NOT be enabled in uTorrent.

Did you disable Resolve IPs?

Bandwidth Management (uTP) disabled for testing?

Disable/block IPv6 or Teredo/IPv6?

Are you on ADSL?

Did you configure your modem if you are, as it probably has a mini-router in it which would block incoming connections.

Share this post


Link to post
Share on other sites

Mate, I had just about the same problem, plus it was impossible to go through the web with the utorrent on, ( I have the same router as you have td-w8910g), the solution for this problem was the weirdest of all, I just deleted the portfowarding rules on the router... and it seems to be perfectly working right now.... super uh? with the "green icon" on utorrent and everything.

Share this post


Link to post
Share on other sites

@ Priceless, Your uPnP and NAT settings were probably conflicting with the Port-forwarding. It's recommended that you only have one of the three enabled. In rare cases (like your own) uPnP can basically undo the forward. However that also means that you didn't need to forward, so continue using uPnP and it should work well for you.

Share this post


Link to post
Share on other sites

I have just tried Your next clues, that is:

1.disabled Resolve IPs

2.disabled uTP

3.disabled IPv6/Teredo...

but none of them worked, i still have something like 0,5kB/s on download. I decided to again change settings to default and again, everything went back as on begining, so now i get approx 20kB/s.

But i have found some overseeded torrent (2x more seeds than peers) and i have got approx 500kB/s on download (and 30kB/s on upload, normally i have 20kB/s down., 1kB/s up)! So i tried few more torrents to testing, some of them had about 200peers some 20k (lol), and some 20 peers, but none of them worked normaly, only THAT one overseeded torrent.

Now i really do not know what the... is happening. Some more solutions?

EDIT:

Just checked next overseeded torrent (something like 15x more seeds than peers!), and got approx 350kB/s on download, but now upload was very low, 0,5kB/s.

Best regards, dlzmu5

Share this post


Link to post
Share on other sites

dlzmu5, try blowing away uTorrent's settings.dat file and replacing it with a new settings.dat file that's 0 bytes in size. This should force "fresh" settings into uTorrent, as I fear somehow your settings.dat file got corrupted. :(

Share this post


Link to post
Share on other sites

Hmm, by reseting to defaults I meant uninstalling and downloading new copy of Utorrent (2.0.4), because i thought same as You. After all of these changes, corrupting settings is very probable. :P So now i have clean Utorrent with settings, which Setup Guide set.

Best regards, dlzmu5

Share this post


Link to post
Share on other sites

I have just checked if i can download torrents with another program than Utorrent, and i have choosen Azureus Vuze. I installed it and picked up some torrent with lots of seeds and peers, and what was strange, my download speed was growing up really fast. When it reached approx 150 kB/s i turned off Vuze, and tried same torrent with Utorrrent. And what happened was even more strange.... download speed was groing up as in Vuze up to 150kB/s but when it reached that level, it just felt down again to 2 kB/s.

What is next, i tried to download torrent with modem instead of router. Picked up same torrent in Utorrent again and left torrent to download. When i came back, i saw that download speed was growing up slowly and reached approx 100 kB/s, and then it was falling down again to 2kB/s. But upload speed was always on max level when i used modem, so now i am sure that my router blocks uploading some way, but not downloading.

I will try again using Vuze and check if the download speed will not fall down.

EDIT:

Checked Vuze working on modem: downloading reached approx 70 kB/s, then felt down to 0 kB/s and downloading just stopped...

Best regards, dlzmu5

Share this post


Link to post
Share on other sites

Google for problems with your particular modem model.

Maybe an updated firmware or modem settings workarounds exist?

Share this post


Link to post
Share on other sites

I could search for such a thing, but i think that have no sense for me, due to that i share my connection with second computer, so i can not use modem instead of router. I also think that problem is not occured by router or modem because on both of them problem still exist. :(

My router's firmware is up-to-date, but i do not know if i can change something in its setting, because i am not familiar with net administrating and all sort of such things...

Best regards, dlzmu5

Share this post


Link to post
Share on other sites

Did you find and disable the modem's SPI firewall? That can do UDP flood protection as well, which almost always gets triggered and starts blocking too much when uTorrent's uTP (UDP packets) is active.

Share this post


Link to post
Share on other sites

I have just checked all router's tabs but i only found something similar in name to SPI, called SIP, but i think that is something far, far different to SPI...:

spifirewall.th.png

Share this post


Link to post
Share on other sites

DreadWingKnight, thanks for Your interest about my problem. :)

I have just checked Security tab, but i found there only something called IP filtering for both outgoing and incoming traffic, and some "Parental Control" (lol :P)

sec1.th.png

sec2.th.png

Best regards, dlzmu5

Share this post


Link to post
Share on other sites

I have checked my router's log but i do not know what to do with it :P, maybe You should take a look on it. I grabbed some random torrent and started Utorrend on Sep 4 10:43:39 (search for that in log). Download speed was very variable what You can see on graph (upload was approx 55 kB/s):

graphty.th.png

graph2u.th.png

Here is link with my log:

http://www.speedyshare.com/files/24105708/logview.cmd.htm

Best regards, dlzmu5

Share this post


Link to post
Share on other sites