Jump to content

HTTP 400 error with NOD32? Look here!


Recommended Posts

HTTP 400 errors on tracker requests and RSS feeds is a result of a serious bug with NOD32's IMON.

Contact NOD32 support and get them to fix this issue. http://www.eset.com/support/contact.php

If you wish, you can give them alus's e-mail (the head developer) if they need a more detailed description or help troubleshooting. greg@bittorrent.com

Upgrade to NOD32 3.x, or add µTorrent to IMON's exception list. Or, disable IMON altogether.

Something you may need to do on Smart Security: http://forum.utorrent.com/viewtopic.php?pid=312475#p312475

Link to comment
Share on other sites


I wrote about the problem to the Czech support - servis@eset.cz - http://www.eset.cz/spolecnost/kontakty

On the Slovak pages (developers) there is no mail, only web form...

More: http://forum.utorrent.com/viewtopic.php?pid=310278#p310278



Don't forget that NOD32 2.7 and it's IMON is older version. Pressent version is 3.0. Free update from 2.7 to 3.0 .

Note: But for users which use Windows 98 (Rafi :P ) - NOD32 2.7 is latest version.


Is this also a problem with their more current version 3.x ?

No. There is no problems in version 3.0.

Link to comment
Share on other sites


I tested both NOD32 2.7 and 3.0 Antivirus (not Smart Security). I have problems only with 2.7.

But I am not ESET developer. I dont know, what is inside NOD32...

I also tested avast! 4.7 Home (P2P plugin disabled). There is no problem.



Dobry den,

Sme si vedomi, ze modul IMON sposoboval tieto problemy. Ostatne preto sa vo verzii 3.0 nenachadza.

S IMONom mali problemy rozne aplikacie, typicky klient-server programy. Bolo to sposobene tym, ze IMON bezi na tak trochu "nestastnej" vrstve Winsock.

Pripadne konflikty s modulom IMON je potrebne riesit bud:

a) specifikovanim vyjimky na adresar/e uTorrent v menu IMON - Nastaveni - karta Ostatni - tlacidlo Editovat. Ak to nezaberie, tak

B) vypnutim modulu IMON, a to tlacidlom UKONCIT a naslednym restartom systemu.

Kedze ide v pripade IMONu len o pridavnu vrstvu ochrany, jeho vypnutie neznamena ohrozenie bezpecnosti. Pripadne infiltracie, ktore by IMON zachytil, eliminuje za jeho nepritomnosti modul AMON /rezidentna ochrana/.

Prajem Vam pekny den.

S pozdravem

Tomas Kotrik


we know that the IMON does problems you described. This is the reason why there is no IMON in version 3.0.

Lots of different aplications have problems with IMON, typicaly client-server programs. The reason is IMON runs on "bad" layer Winsock.

There are two different solutions of IMON problems:

a) Make an exception to the uTorrent dirrectory in IMON Menu - Settings - Other - Edit.

B) Disable IMON and restart Windows. IMON is only secondary layer of protection. If IMON is disabled AMON /resident protection/ fill its job. There is no security risk.

Have a nice day.

Best regards

Tomas Kotrik

Link to comment
Share on other sites

An ESET Customer Care Representative has updated this case with the following information:


Please do the following:

1. Open ESET Smart Security by clicking the icon in your Windows system tray.

2. Enter the Advanced setup tree (press F5).

3. Navigate to Personal firewall. In the right, change Filtering mode to Interactive mode.

4. Go to Personal firewall > Rules and zones. In the right (at the Trusted zone part) click Setup and choose "Allow sharing".

5. Navigate to Personal firewall > IDS and Advanced options. Make sure all services are allowed.

6. Confirm with OK.

See if that helps.

Link to comment
Share on other sites

  • 3 months later...
  • 1 month later...

For NOD32 2.7, just go in configuration IMON in NOD32, go to the Advanced tab and then in "Exclusion" and add the executable of utorrent.

Reviving utorrent and there is no longer a problem error "HTTP 400 error" with the Trackers.

[in french]

Pour NOD32 2.7, il suffit d'aller dans configuration de IMON dans NOD32, aller dans l'onglet "Avancé" puis dans "Exclusion" et ajouter l'executable de utorrent.

Relancer utorrent et il n'y a plus de problème d'erreur "HTTP 400 error" avec les Trackers.

Link to comment
Share on other sites

As soon as I started Utorrent my Web browser stopped working, it was just waiting for the web page after it was found and then it did timeout. The weird thing was that my Utorrent did work, my windows live messenger did work, and I could remote control my pc, all other computers was working in the network. But neither my Internet Explorer 7.0 or my Mozilla Firefox 2/3 was working.

This problem just started some month ago and I couldn't figure whats started it, I hadn't change anything (Hardware or software).

I did try the following:

Uninstall all programs that I didn't use (didn't have so many).

Updated my network card drivers.

Removed / Uninstall all unused network protocol.

Restored my Utorrent settings to default.

Lowered my Global max connection.

Changed the forward port, did even try without forward a port.

Disabled DHT.

Some other stuffs I can't remember.

Reinstalled my computer (using Vista ultimate x64).

Nothing of this helped but then I managed to figure out what was wrong. My problem did start cause of a NOD32 update. What I did to solve the problem was:

Open NOD32 and go to Advanced options (F5). Then go to Antivirus and antispyware -> Web access protection -> HTTP -> Web browsers and uncheck Utorrent. Reboot the computer.

I guess that nod32 did block all "web browsers" for some reason since it thinks that Utorrent are a web browser.

Link to comment
Share on other sites

not sure if it is a nod32 issue or a uTorrent issue, probably it depends on whom you ask: uTorrent people or eset people, after all everything was ok with uTorrent 1.7.7.

Anyway, disabling imon solves the problem.

Adding uTorrent to the imon exclusion list also solves the problem,

both solutions tested succesfully with nod32 2.7 antivirus only version

Link to comment
Share on other sites

Could someone please explain why this is classified as an ESET or NOD32 problem if the problem only started upon upgrade to Utorrent version 1.8. I've been using Utorrent version 1.7.7 for ages with no problems at all ,but now after upgrading to version 1.8 all my trackers are showing "offline (timed out)". Should I disable IMON or go back to Utorrent 1.7.7.?

Link to comment
Share on other sites

Thank you Dreadwingknight for your quick reply. I have followed your advice and disabled IMON. However, my trackers are still showing as "offline (timed out)", with the red arrow showing by the torrent. I have not changed any settings from how they were in Utorrent version 1.7.7. which were all the recommended ones and which all worked fine.

What now?

Link to comment
Share on other sites

I had ESET NOD32 Smart Security 3 (I don't think Smart Security is actually NOD32 but my software said both) and uTorrent 1.8 BETA worked fine without me having to do anything. My browsers also worked fine for the most part (I had a browser freeze problem because of uTorrent, not ESET, but that's since been resolved) and like I said, I didn't do anything to the settings of ESET.

I don't know how you guys are having problems or how I wasn't having problems, but I just thought I'd share that with you.

This was on Windows Vista Home Premium RC1. But I have moved onto SP1 and haven't checked ESET (since my subscription ran out prior to downloading/updating to SP1) to know if SP1 has a compatibility issue or anything. I'll probably reupdate after my BitDefender Internet Security 2009 subscription ends... I liked ESET.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...