Archived

This topic is now archived and is closed to further replies.

1c3d0g

[DON'T USE] Mini-guide to help all of you with your speed problems...

Recommended Posts

First, a little story:

When i first installed µ i got about about 10 times less speed than in BitComet,

I followed this and Martin Levac's guide and i actually got to max out my down speed!!! Great job!

But what if we make a little request:

Why can't this be implemented in the next version of µ?

It will definetly help the torrent comunity and... "force" everyone to be fair!

Besides it can help new users use torrents "the right way".

And i think we can all benefit from that.(achieve greater speeds and faster torrents)

Or, at the very least, it can be released as an alternate build!

Just a thought!

Share this post


Link to post
Share on other sites

The patch for TCPIP.sys, and the optimized values based on 1c3d0g's and Martin Levac's tweaks and the users connection. And based on these values (that depend on the connection), an automatic nr of up and down slots; and the limits for both up and down speeds.

From my own experience these ones work better than the ones that µ recomended me. *i have 1.5(build 437)

In fewer words turn 1c3d0g's and Martin Levac's tweaks into the recomended values for µ!

Like i said: Just a thought!

Share this post


Link to post
Share on other sites

Well the TCPIP.sys patch is only for Windows XP SP2, and not everybody has that specific version. ;) The built-in speedguide also has some optimal settings, though my settings are often called "insane" or "excessive" compared to others. We'll see. :P

Share this post


Link to post
Share on other sites

Yeah it works fine, but some people's net connections get screwed over without the patch, or without lowering net.max_halfopen (which would decrease connection rate even further).

Share this post


Link to post
Share on other sites

1c3d0g, if you could please PM me direct help, I would be grateful. The torrent I want has 1349 seeders, and almost twice as many leechers. I am using comcast.net 5 megabyte/second ISP, I did everything the post told me, used the script thing which tells me which values to plug in, but I still get low DL speeds, usually 0.00 kB/s. On good days, I get 0.8 kB/s. Could you possibly help in any way?

Thanks for your time and effort,

aoetwo

Share this post


Link to post
Share on other sites

aoetwo: sorry for not getting back to you sooner, but I had tons of things to do. Saying that, I'll go straight to the point:

1.) Do you see a green light in your status bar or not?

2.) Have you enabled Protocol Encryption (not Forced) and DHT/PeX?

Share this post


Link to post
Share on other sites

you probably have a firewall blocking things, or the tracker's down/inaccessible/etc. Also, your speeds are 5 megaBITS, not bytes.

Share this post


Link to post
Share on other sites

Thank your for an extremely exhaustive and helpful mini-guide which I followed to the letter as best I could. My DSL connection speed is 1500/256 kb/s and my wireless router is D-Link dl-524

On doing so I am getting what I consider to be good d/l (average 47kb/s and u/l(average 25kb/s) speeds which by the way are much better than other bitorrent clients I had used in the past however I have two problems which in no way intended to be a complaint in any way.

Firstly, after setting portforward in accordance with the information contained in the link the Logger states "unable to map UPnP to 192.168.x.x:32495

Secondly,I patched my TCPIP.sys file using LvlLord's helpful scrip which I assume is EvID4226Patch223d-en. The patch is to do with how many "maximum conconcurrent half-open connections" which I again assume increases winxp default 10 to 50 . If I attempt to key in the number of my upload speed which is 256 as per your guide, I receive a warning message essentially telling me not to.

Any help you or any of the members are able to give will be appreciated. The only other request I make is that you give me fair warning if you are going to attack me with that baseball bat :)

Share this post


Link to post
Share on other sites

I've put away my baseball bat. You can come out now. :P

1.) Ignore the warning. If you've port forwarded manually, there's no need for UPnP, hence that "error" message. P.S. make sure you've unselected "Enable UPnP port mapping (Windows XP or later only)". ;)

2.) You can safely ignore that warning as well. They've put it in there for people who don't know what they're doing, but since you and I do know what we're doing, that warning does not apply to us. ;)

Share this post


Link to post
Share on other sites

Thanks Icedog and Firon...very helpful and will implement.

Guys just to let you know I'm prolly old enough to be your grand-dad and since I've become addicted to the arkane world of IT generally my only regret that I wont be around when the effect of the technology evolves to the point that it will rival the second coming of whatever diety one happens to believes in :)

Share this post


Link to post
Share on other sites

I seem to be downloading fine but just a quick question:

Is the following download speed correct for a 2mb connection?

Green Light on

Followed Quick Guide

Download P2P of Open Office and Average Download Spead of 142 kB/s

No wireless just direct from Modem (NTL) to Ethernet port on Desktop

Any clarification appreciated.

Share this post


Link to post
Share on other sites

It could have been a bit faster (like around 200 kB/s), but I don't know if you had anything running in the background that could slow it down. The OOo torrent usually maxes out most connections. In either case it's certainly not a bad speed... ;)

Share this post


Link to post
Share on other sites
UPnP should be turned off on any D-Link router, they are often unstable with it turned on

Done that in the router's config settings as well as uninstalled UPnP from windows xp sp2 add/remove window components, disabled Windows software firewall and still receiving Logger error "unable to map UPnP port to 192.168.x.x:32459".

As always, I appreciate any advice given by those more informed than I.

Share this post


Link to post
Share on other sites
It could have been a bit faster (like around 200 kB/s), but I don't know if you had anything running in the background that could slow it down. The OOo torrent usually maxes out most connections. In either case it's certainly not a bad speed... ;)

Thanks 1c3d0g, much appreciated. I checked NTL website and for 2mb connection says max download 256 kB/s upload 25 kB/s.

Upload seems fine averaging about 20 kB/s so that part seems fine. Just dowlnoad at 140 kB/s.

I am running in background

Zone Alarm Free Version

Norman Virus Control

Tune Up Utilities 2006 (Which changes settings for 2mb connection, not sure what though)

Spybot SD - Resident

Nothing else I can see which would make a difference (could be wrong).

I may try OpenOffice over 3-5 occassions and jot down the average download speed to see what it gives.

Any other help appreciated.

Share this post


Link to post
Share on other sites

It's known that ZoneAlarm can block legitimate packets from getting through, which means things have to be re-sent over and over again. That's the only thing I could think of.

Share this post


Link to post
Share on other sites
It's known that ZoneAlarm can block legitimate packets from getting through, which means things have to be re-sent over and over again. That's the only thing I could think of.

Hello 1c3d0g again,

Cheers for reply.

I checked Openoffice twice (cant stare at screen anymore must have something better to do!!!) and:

Maxed out on Download at 240 kB/s

Averaged on both occassions at 230.3 kB/s

I think I can live with that.

The only thing I changed after previous post was checked in msconfig on what was starting up and removed more than half of items which I will rarely or never used.

Seems to have worked a treat and quicker startup on computer and more stable.

Still have:

Zonealarm

Norman Virus Control

Spybot SD - Resident

Tuneup Utilities 2006 Mem Optimizer

Share this post


Link to post
Share on other sites

This may have been answered before, but it's a pretty long topic so I'll just put in a post about it.

You write:

Another very important thing you need to do is to patch your TCPIP.sys file. If you don't know what this, don't worry. Just surf over to our German friend LvlLord and download the appropiate patch for your OS. When the download has finished, double-click the program and press C on your keyboard. Then, type in the number of your upload speed in kb/s (notice the small "b", thus kilobits), in our situation it was 128 kb/s, so we'll type in 128.

Why such a high number? And on what basis did you decide to use the upload speed in kbits?? For people with larger bandwiths, they can put 1000 on that patch or even higher. I have been warned by others not to put this higher than 100, so why do you use the upload as an estimate?

Next question is about the Maximum number of connected peers per torrent, you say divide your upload by 8 and use the number you get, in your case 16. Is it just me or is this value very low? If I let uTorrent use recommended settings on that bandwith it is set to 55.

Thanks for a very good guide by the way, it really helped on my download speed in uTorrent.

Share this post


Link to post
Share on other sites

1.) Because people keep complaining that µTorrent "ramps up slowly". Well, the patch fixes that and still allows enough connections for aggressive surfing/multiple downloads (FTP etc.) at the same time. You can lower it if don't think you'll need that much. The guide is not the end all be all. ;)

2.) Yes, that's what I use and on most torrents I get great speeds. Too many connections will steal your bandwidth because µTorrent has to keep communication with all those peers, most of them which you'll not receive anything. It's better to have a few peers uploading to you @ > 5 kB/s than dozens of peers @ < 0.3 kB/s... Then again, if 55 peers works better for you, hey, nobody's stopping you. Use what works for you. ;)

Share this post


Link to post
Share on other sites

Ok, but about the TCPIP-patch, I've read alot and heard alot about it. Some says it's useless, som says it's really helpful. And as I understand, it's the amount of incomplete connections that can be attempted per second. I haven't really tested different settings with this patch on uTorrent, but I will and see if it really helps as much as some people claim it does.

It's also a matter of security, by adjusting this number, the risk of spreading a virus before the AV is updated about it is increasing by every connection attempt you add. This I've read, I'll put down a link while I'm at it http://www.neowin.net/forum/lofiversion/index.php/t267665.html

Share this post


Link to post
Share on other sites

Its usefulness is different for each person. Some people have problems while torrenting and using their internet connection without this patch, while others never have problems either way. Yes, setting it too high can be a security risk as well, which is why 50-100 is considered a decent balance, as it still slows any such virus down.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.