Jump to content

uTorrent v2.x/3.x - Best Practice Tips


rafi
 Share

Recommended Posts

  • 4 weeks later...

@rafi:

Concerning net.utp_initial_packet_size, you recommend using MTU size (which is 1460 for my ISP), but uTorrent help says the maximum value is 8 (x 150 = 1200). Is this right? If so, any reason known for why this setting doesn't go any higher, or is there no benefit to be gained by more closely matching MTU (uTP still lags behind TCP in raw speed and stability for me)?

Link to comment
Share on other sites

quoting myself... -

2b. Set pref->advanced->net.utp_initial_packet_size = 8 (use MTU size)

8 = use MTU size... as far as I know. Anyway, measurements show that 8 uses ~1440 I think, since they were too lazy to figure the MTU size out... :P

Edited by rafi
Link to comment
Share on other sites

Well, it's just that the uT help says:

This option is interpreted as a multiplier of 150 bytes, so please enter it as such. Any value below 1 will be ignored (and 1 will be used instead), and any value above 8 will be ignored (and 8 will be used instead). Effectively, that means that the initial packet sizes selectable by the user are the multiples of 150 bytes between (and including) 150 bytes and 1200 bytes.

But if you're right, I guess you've answered my question, regardless. Thanks.

Link to comment
Share on other sites

But if you're right, I guess you've answered my question, regardless. Thanks.

I am right (you can check in various ports of mine, with Wireshark cap file details)... You can report it as a "bug" in the help file... ;)

Edited by rafi
Link to comment
Share on other sites

i've utorrent 3.0, but it stopped working suddenly..it's not getting connected to the server. yesterday it was working properly then suddenly the downloads stopped. i reinstalled it 4 times, still no progress..I'm not getting the 'TRACKERS' Icon in my utorrent app. I tried the set up guide also. My getting started page says "npt was made to access a socket in a way forbidden by its access permission. Please check your internet connection and try again" my net is perfect.

Please Help ASAP!!!!!!!!!

Link to comment
Share on other sites

DEAR FRIENDS n ADVISERS..

Installed latest Utrrent3.0 2 days back. Since then, I can't download anything. My programme says for all my running download and newly added downloads-----

seed 0(0) peer 0(0).

DHT:Waiting to Log in ....

Upload Speed: 0.0 KB/s

Download Speed: 0.0 KB/s

----------------------------------------

I have switched my ISP.....3times to check if there's anything complicated with the ISP setting..(from USB net modem to broadband to wifi) It's all the same...

I dont use any kind of InterNet Security Software for some time now...

Checked and confirmed to keep utorrent 2 in the "Windows Firewall" exception list...

BUT...Nothing is working...Please Help. Regards in Advance

Link to comment
Share on other sites

first of all ty for creating a guide for us but it seems too technical for me to understand lol.. i was planning for the quick fix option but when i click on 250 the file says 500 and when i click 500 the file says 250 so which one is which..

again kudos to you for helping us out..

ps if you have another one with speeds around 50 to 100 that would be nice as well.. our connection sucks bad here in the philippines :D

Link to comment
Share on other sites

Thanks for the feedback. I fixed the 250<->500 swap error . Regarding 50KB/s or 100KB/s, just use the 250K file, and then set your *upload* speed manually in the perf->bandwidth . Reduce the # if upload slots by ~50% as well.

You can also see the recommended settings for your speed in the "setup" guide (ctrl-G).

Edited by rafi
Link to comment
Share on other sites

The download works fine for me... but, yeah, they are both OK in case you change the upload rate limit . Just reduce the slots # a bit more.

Just keep in mind that the files are for 250/500/1000K*bit*/sec. uTorrent sets it in K*Byte*/sec which is /8 of those numbers!

Edited by rafi
Link to comment
Share on other sites

Good thing you cleared that out. Was thinking dam our service here is really taht slow. I think I can go 500 but given our isp is inconsistent i'll just use 250 :D

my bad regarding the download. there was a problem with chrome. It wont let me dl it twice. I am using your 250 setup right now and its working great.

One last question though how does the port affect downloading should i just leave it at 50000?

Thanks again ;)

Link to comment
Share on other sites

50000 is fine. any number is fine, as long as it is not USED already in your system and is not a "well known"/in-use port

http://en.wikipedia.org/wiki/List_of_TCP_and_UDP_port_numbers

It is usually considered better to use high numbers above 49152, but I think there is no evidence to support that theory, except that it assures you do not use any "well known" port by mistake. Even if you do - I think there is no real harm if you do not need it's service.

Link to comment
Share on other sites

just an update.. 250 worked great rafi!! no lag with browsers and other applications.. my pc doesnt look like its having a hard time when utorrent is on.. thanks again..

sucks though my hd suddenly got an error "windows detected a hard drive problem" just when i was about to download everything i can want.. sigh..

Link to comment
Share on other sites

I have a 512 KB internet connection and I did the speed test on my internet service provider's speed test page and I got a 72.1 KB/sec download rate and a 33.1 KB/sec upload rate. So I set my upload rate to 256 kbits/sec. I have just recently upgraded utorrent from v2.0.2 to v3.0. The problem is that I used to get about 40 kB/sec to 60 kB/sec from utorrent 2.0.2 but now I only get about 20 kB/sec - 30 kB/sec.

Link to comment
Share on other sites

  • 2 weeks later...

GREAT POST... ("and might tasty, too!")

Was having some memory probs -- nothing major, but perfectionist that I am....

LSS: "A; 1b" did the trick (tho seemed counter-intuitive at first), i.e. "disable/enable memory cache when not using...yatta-yatta" <can't remember the exact wording & closed the tab, sorry can't give an exact quote but AM certain was "A; 1b">) helped immeasurably!

Also, tho was getting better DL/UL speeds than my friends, played w/ your tips & made my speed/s "even betterer!" ;) (The "use 80%-95% of recc'd UL speed," was a particularly helpful tip.)

AND, coz security is *always* a concern (spkg of intruders, not any illegality/copyright issues. Artist/writer that I am, am particular sensitive to "creative propty rights") -- did some tweaking in that dep't as well. (Instead of guard dog protection I feel I've an army of mercenaries standing guard!)

All in all, you get a 10 outta 10. (IOW: If you don't find help for your problem here? It's probably YOU. [An improper install; some nasties in your system; having misconfigured something somewhere along the lines, etc.])

Was "simple to understand (i.e., "cyber-idiot friendly"); even simpler to initiate; well-organized... Heck, you even get an "A+ for both grammar AND spelling. (As a prof. writer, am often horrified for what passes as "proper English," now'days. Talk about the "dumbing of America!")

In closing, THANKS, rafi, for a wonderfully helpful post! (Users would be well-advised to try all suggestions --whether or not you THINK you're having probs in that area -- one at a TIME!

Keep the tab of the area you're tweaking open (iow, when tweaking speed settings, open your "Speed" tab), make the change, watch for its effects & unDO what has negative &/or no effect. (IOW: "If it ain't broke...")

Love & Light!

Silver & The Wonder Dog :cool:

PS: Note to poster "kanti: was it? (Was *something* similar... am SURE it began w/ a "k" at least :rolleyes:;-D) ... The (French) word you were searching for is spelled "Voila," not "Wola." (Think "Wola" is a Polish delicacy or a nickname for a Polish boy or... LOL ~ S'okay. you tried and THAT's what counts. IOW: an "'E' for effort," in my book!)

Edited by silverbonn
Link to comment
Share on other sites

Thanks so much for these tips, they are a big help.

Does anyone know how to use the unrar command line to extract to a specific folder with no sub folder? I've been using:

"c:\program files\winrar\winrar.exe" x -ibck -ad "%D\*.r*" "%D"

Also tried: "c:\program files\winrar\winrar.exe" x -ibck -ad "%D\*.r*" "Z:\TV\"

and "c:\program files\winrar\winrar.exe" e -ibck -ad "%D\*.r*" "Z:\TV\"

In all cases though it still ends up in a subfolder of the Z:\TV\ folder. I'd love the file to just be put right in the directory... thanks!

Link to comment
Share on other sites

This is the command definition:

To extract files, including their paths:

WINRAR X [ -switches ] <Archive> [ Files ] [ @File lists ] [ Destination folder\ ]

To extract files, ignoring paths:

WINRAR E [ -switches ] <Archive> [ Files ] [ @File lists ] [ Destination folder\ ]

With "X" - It all depends on how the files are arranged INSIDE the rar.

It is also possible that when you use "E" you might end up with issues IF files with similar names are located in different sub-folders.

BTW, you have a complete guide (with a chapter on command line mode) here:

http://acritum.com/software/manuals/winrar/

Edited by rafi
Link to comment
Share on other sites

This is the command definition:
To extract files, including their paths:

WINRAR X [ -switches ] <Archive> [ Files ] [ @File lists ] [ Destination folder\ ]

To extract files, ignoring paths:

WINRAR E [ -switches ] <Archive> [ Files ] [ @File lists ] [ Destination folder\ ]

With "X" - It all depends on how the files are arranged INSIDE the rar.

It is also possible that when you use "E" you might end up with issues IF files with similar names are located in different sub-folders.

BTW, you have a complete guide (with a chapter on command line mode) here:

http://acritum.com/software/manuals/winrar/

This command should work for what I'm trying to do:

"c:\program files\winrar\winrar.exe" e -ibck -ad "%D\*.r*" "Z:\TV\"

E should ignore the paths and just extract the file to Z:\TV but for some reason it creates a folder, for example Z:\TV\rarname\rarname.mkv

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...