Jump to content

WebUI v0.315


Directrix

Recommended Posts

  • Replies 1.3k
  • Created
  • Last Reply

Top Posters In This Topic

Thanks Directrix. WebUI works just fine but it happens that µTorrent stops answering by unknown reason -- i can see only "Loading" all the time. µTorrent works well (no error messages or anything of the kind) but i can't communicate with it.

Source machine: MAC OS X 10.4.7, Intel Core Duo, Mozilla FireFox (the last).

Destination machine: W2k pro SP4, µTorrent and WebUI 1.6.1 b481

webuikr1.th.jpg

Thanks.

Link to comment
Share on other sites

Ok, ive been testing and it did the job flawlessly, but i have a question, im sure youre familiar with the example posted on slyck.com about the guy on vacations http://slyck.com/forums/viewtopic.php?t=26153.

My question is, suppose the hypothetical case were you are at home and want to download a torrent from a public connection of shared IPs usin the Webui (i.e. the opposite of the slycks example), would it work? Ive been trying but i couldnt connect to the Webui. Is it possible to do so?

Link to comment
Share on other sites

Awesome. I am a no-ip subscriber, combine that with firefox, and your Web UI.....WOW!!! Life is grand. You guys are doing a great job, I'm impressed. I've used alot of clients and just recently installed utorrent. I have to say I think I've been missing alot. Now if I can just get the client tweaked, upload speed a little lacking, and I've just started configuring. But all around excelent job guys.;)

Link to comment
Share on other sites

Some users are reporting a problem where the WebUI hangs at the "Loading..." screen. I had the same problem using FireFox + NoScript. This solved the problem for me:

- Open the "webui.zip"-file in your Application Data\uTorrent folder using WinZip

- Open the file "index.html" from inside the zip

- Look for 4 lines like this one (line 9-12):

<script type="text/javascript" src="./common.js"></script>

- Remove the "./" before the file names (so src="./common.js" becomes src="common.js"); do this for all 4 lines

- Save the file and close the editor; WinZip will now ask if you want to update webui.zip with the changes you made to index.html. Choose "Yes".

- Restart uTorrent

Another solution was to tell NoScript to allow scripts globally (simply allowing localhost:port didn't work).

Good luck :)

Link to comment
Share on other sites

Glival, that's pretty sweet. I have since edited the page and restarted uTorrent such that now in my browser at work viewing the source shows lines 9 through 12:

<script type="text/javascript" src="common.js"></script><script type="text/javascript" src="stable.js"></script><script type="text/javascript" src="script.js"></script><script type="text/javascript" src="content.js" defer="defer"></script>

Unfortunately, I'm still stuck at the "Loading..." in the middle of the screen in Firefox. Does "./" just mean it's pulling from the current directory? If so, why not let it be a vanilla relative URI? Either way, I've modified the index.html to remove ALL "./" from in front of anything, which includes the following three lines in addition to the ones shown above:

Lines 7 and 8 (obviously the favicon is unlikely to matter, though the style.css might well be important):

<link href="favicon.ico" rel="SHORTCUT ICON" /><link href="style.css" rel="stylesheet" type="text/css" />

Line 23:

<form action="?action=add-file" method="post" enctype="multipart/form-data" target="uploadfrm" onsubmit="return CheckUpload(this);">

And now it works! Yay! I know I modified the form action to add a file, so I tested it out, and it works well even without the "./" prepended to it.

PS Yes, Firefox 1.5.0.7 with the NoScript extension among others. In case it proves useful for future reference, here's my complete extensions list:

extensionsxw7.png

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

Guest
This topic is now closed to further replies.

×
×
  • Create New...