Archived

This topic is now archived and is closed to further replies.

Firon

µTorrent 2.0 beta 17539

Recommended Posts

I spotted this in uTorrent's Logger tab/window when I started uTorrent 2.0 beta 16081:

[2009-08-06 08:07:35] NOTE: Settings file found in directory of executable; using that.

[2009-08-06 08:07:35] Loaded ipfilter.dat (27 entries)

[2009-08-06 08:07:36] Error: Could not load IsHungAppWindow

[2009-08-06 08:07:36] *** Starting Diagnostic thread ***

[2009-08-06 08:07:36] Exiting Diagnostic thread with status:

[2009-08-06 08:07:36] WAIT_FAILED:

[2009-08-06 08:07:36] The handle is invalid.

This is on Windows 98SE...so I don't know if it's important or not.

Share this post


Link to post
Share on other sites

Hi Everyone, Thanks for all the feedback.

Switeck: Good eye. Yes, that is expected. The new feature that looks for hang problems uses an API (IsHungAppWindow) that only exists on win2k and later. (we are seeing some problems on Vista). I'll change that to be more informative.

guijarrelson: Thanks; looking into this.

unforgiven_sh: You should see consistent numbers on the same server; however, the numbers vary widely from server to server.

We'll be working with Mlabs to get more servers online, and to make it easier to choose the server that will give you the most accurate results.

Share this post


Link to post
Share on other sites

AdamK: i wasnt talking about the speed guide nor the speed test, i meant transfer speeds. i went few times today changing between 1.8.3 and 2b without changing any settings and as a result i got straight lines (both u/l and d/l) in 1.8.3 and zig-zag looking graph in 2b. also tried disabling "Enable bandwidth management" to see if the low transfers speeds were uTP related but this seems not to be the case, the same speed drops and rises were happening again

edit:

added some screenshots

http://img15.imageshack.us/img15/218/183r.jpg

http://img21.imageshack.us/img21/1214/39311141.jpg

Share this post


Link to post
Share on other sites
After choosing New York #2 test menu goes crazy, so I could not stop it except by process killing...

same here. a stop/cancel button can be useful. I would use the 'v' shape (or "passed" instead of + .

& I don't like this 'fully-automated' settings after those tests :( Can you please leave the old method as well ?

edit:

also - the "run test" button should re-enable itself after the test is done (so to be able to re-run it).

edit(2):

crash dump - during setup test...

http://www.mediafire.com/?e9d2z1rlgis

... and this is definitely still an alpha quality, not beta... :P

Share this post


Link to post
Share on other sites

Does uTorrent periodically retry when it fails to bind to the configured port? If it does, it doesn't look like it's working, otherwise, would be great if it did.

(OT: if it said what process was holding the port, that would be really useful. Oh and a "try again" button...)

The crashes seem more frequent when I'm actively interacting with my computer (not uTorrent), seems to crash every few hours when I'm using my computer, but can go overnight most of the time.

--

On my newly installed copy of w7:

torrentnotrespondingred.png

I don't have dumps because I haven't installed Debugging Tools for Windows yet, and they were hangs, not crashes.

Share this post


Link to post
Share on other sites

Transfer cap? What the hell is that?

I deleted the help file, and uTorrent download v1.8.3 help one. In the install, uTorrent could check if the help file exists, and delete it to download the latest.

Greets ! ;)

Share this post


Link to post
Share on other sites

@unforgiven_sh: looks like a uTP issue. I thought it was "improved" ... u can try TCP only (bt.transp_disposition=5) to confirm.

Share this post


Link to post
Share on other sites

@evox2008: The invalid tracker announce and the https crash are 2 separate bugs.

@rafi: "same here. a stop/cancel button can be useful. I would use the 'v' shape (or "passed" instead of + .

& I don't like this 'fully-automated' settings after those tests :( Can you please leave the old method as well ?"

You mean the drop-down of presets?

"and this is definitely still an alpha quality, not beta... :P"

It may help the engineers pushing back on adding more features though :P

@torrenteer: "Are IPv6 UDP trackers supported?"

The UDP tracker spec doesn't support IPv6.

Share this post


Link to post
Share on other sites

>You mean the drop-down of presets?

yes . since the UL measurement from "your" test servers is completely off scale (from here) , try design a dialog to combine both the old and new methods. I can think of a way to auto -select from the ULs drop-down list based on the test result, but still be able to change it manually before you press "apply".

Can you say a few words on how the tests results are utilized ? based on UL speed only as before ?

And pleeeease re-enable the test button after the test is done... :)

Share this post


Link to post
Share on other sites

"Can you say a few words on how the tests results are utilized ? based on UL speed only as before ?"

Yes, we still use the same list of presets, and find the one with the upload rate closest to your measurement.

Share this post


Link to post
Share on other sites
Hi Everyone, Thanks for all the feedback.

Switeck: Good eye. Yes, that is expected. The new feature that looks for hang problems uses an API (IsHungAppWindow) that only exists on win2k and later. (we are seeing some problems on Vista). I'll change that to be more informative.

Feh, don't bother fixing it for 9x. :P

Share this post


Link to post
Share on other sites

arvid said, "Yes, we still use the same list of presets, and find the one with the upload rate closest to your measurement."

In light of what I've seen, the presets are bogus and need to be rethought in light of the speed tests being horribly wrong due to burst-capable lines. I've really only got 1 megabit/sec upload speed...but it bursts to nearly 3 megabit/sec upload speed for the duration of the short speed test. uTorrent thinks 2 megabit/sec upload settings are correct...which allows 750 global max connections and way too many torrents at once.

Even if uTP rate-limiting keeps the upload speed under control and what it should be, the excessive number of torrents and connections will not help anyone.

Just as Rafi said, we need access to the old drop-down list to change/correct what uTorrent will otherwise choose for us.

Please reconsider using more conservative default settings, especially for NO settings...because MANY people (probably >25% of all users) will use whatever default NO settings are!

Share this post


Link to post
Share on other sites

I must note that the problem here is different. There is no spike problem here (capped by both the ISP and ADSL providers), and though the UL max is very low (250Kbps / 32KBps) , to most servers I do not even get that much. It's also inconsistent.

And why do you measure DL rate if you don't use it ? Use the time to do 2-3 UL tests instead, and take the max result.

The idea to add UL measurement - is a good one. Just don't make it mandatory to use the results...

Also - please test it some more... there are too many bugs for a beta... let Firon test it, he's good at it .... :P

some test results: http://www.mediafire.com/?mmxwaidxmqm

edit:

arvid:

It may help the engineers pushing back on adding more features though

No problem :) we'll be gentle with them... just don't forget your promise about including also new RSS functionality in V2...

http://forum.utorrent.com/viewtopic.php?id=44903

Share this post


Link to post
Share on other sites

I would like to report that the speed test results did give me settings in line to my actual line speed.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.