Archived

This topic is now archived and is closed to further replies.

Firon

µTorrent 3.0 "Falcon" (32-bit) alpha 25207

Recommended Posts

W7 x64

Can't see peers tab. Can select it, but nothing appears within it. Also get a random horizontal re-size mouse icon in the middle of the torrent listing.

Share this post


Link to post
Share on other sites

Seems like uTorrent is properly closing/unmapping/etc it's UPnP ports on application exit, great. But it seems that it doesn't do the same for the Teredo port 58797@UDP. Would be nice to have this closed on uT exit also.

Could I also suggest a check for bt.transp_disposition, so that if it's set to 10 (UDP only) uT is prevented from mapping a TCP port.

Thanks.

Share this post


Link to post
Share on other sites

Use pretty much any port you want. Port does not directly affect speed. Some say that certain port ranges are less likely to be subjected to traffic shaping by ISPs, but I don't put too much stock in that.

Share this post


Link to post
Share on other sites

[build 18304 - Windows 7 x64]

Clicking a link, without µTorrent running first, results in µTorrent loading but not adding the link (torrent, magnet, etc).

With µTorrent shut down @ the command line:

C:\Program Files (x86)\uTorrent> utorrent test

<starts, no error - because it doesn't attempt to add the file>

With it running already:

C:\Program Files (x86)\uTorrent> utorrent test

<popup in the µTorrent window> Unable to load "test": The system cannot find the file specified. !

I tested at the command line, because I thought at first maybe the associations were corrupt (which they were not). Other people have reported this as well months ago (I see 2 in early Dec), with no fix yet so just posting again with more details. It's a really annoying bug for those that don't have µTorrent autostart with windows (a game I play doesn't play nice with it lol).

Share this post


Link to post
Share on other sites

Why am I getting double connections from the same peers?

83386341.png

36914077.png

This happened while seeding 2 different torrents on 2 different (private) trackers.

Share this post


Link to post
Share on other sites

keep crushing on my pc since 2 versions back...

W7 ULT 32BIT ENG

where to can I upload the crush dumps because it does not send it to you after the crush?

~~~~~~~~~~~~~~~~~~~~~~~~~~``

*reading the crush file I've found this:

Dump Summary

------------

Dump File: C:\Users\Itay\AppData\Roaming\uTorrent\18304-utorrent.7feb.dmp

Last Write Time: 02/03/2010 19:59:45

Process Name: C:\Program Files\uTorrent\uTorrent.exe

Process Architecture: x86

Exception Code: 0xC0000005

Exception Information: The thread tried to read from or write to a virtual address for which it does not have the appropriate access.

Heap Information: Not Present

the complete DMP:

Dump Summary------------Dump File:    C:\Users\Itay\AppData\Roaming\uTorrent\18304-utorrent.7feb.dmpLast Write Time:    02/03/2010 19:59:45Process Name:    C:\Program Files\uTorrent\uTorrent.exeProcess Architecture:    x86Exception Code:    0xC0000005Exception Information:    The thread tried to read from or write to a virtual address for which it does not have the appropriate access.Heap Information:    Not Present
System Information------------------OS Version:    6.1.7600CLR Version(s):    
Modules-------Module Name    Module Path    Module Version-----------    -----------    --------------uTorrent.exe    C:\Program Files\uTorrent\uTorrent.exe    2.1.0.18304ntdll.dll    C:\Windows\System32\ntdll.dll    6.1.7600.16385kernel32.dll    C:\Windows\System32\kernel32.dll    6.1.7600.16481KERNELBASE.dll    C:\Windows\System32\KERNELBASE.dll    6.1.7600.16385advapi32.dll    C:\Windows\System32\advapi32.dll    6.1.7600.16385msvcrt.dll    C:\Windows\System32\msvcrt.dll    7.0.7600.16385rpcrt4.dll    C:\Windows\System32\rpcrt4.dll    6.1.7600.16385comctl32.dll    C:\Windows\winsxs\x86_microsoft.windows.common-controls_6595b64144ccf1df_6.0.7600.16385_none_421189da2b7fabfc\comctl32.dll    6.10.7600.16385user32.dll    C:\Windows\System32\user32.dll    6.1.7600.16385shell32.dll    C:\Windows\System32\shell32.dll    6.1.7600.16385ws2_32.dll    C:\Windows\System32\ws2_32.dll    6.1.7600.16385apphelp.dll    C:\Windows\System32\apphelp.dll    6.1.7600.16481ole32.dll    C:\Windows\System32\ole32.dll    6.1.7600.16385uxtheme.dll    C:\Windows\System32\uxtheme.dll    6.1.7600.16385iertutil.dll    C:\Windows\System32\iertutil.dll    8.0.7600.16385AcXtrnal.dll    C:\Windows\AppPatch\AcXtrnal.dll    6.1.7600.16385rasman.dll    C:\Windows\System32\rasman.dll    6.1.7600.16385mswsock.dll    C:\Windows\System32\mswsock.dll    6.1.7600.16385WSHTCPIP.DLL    C:\Windows\System32\WSHTCPIP.DLL    6.1.7600.16385winhttp.dll    C:\Windows\System32\winhttp.dll    6.1.7600.16385ssdpapi.dll    C:\Windows\System32\ssdpapi.dll    6.1.7600.16385msxml3.dll    C:\Windows\System32\msxml3.dll    8.110.7600.16385dbghelp.dll    C:\Windows\System32\dbghelp.dll    6.1.7600.16385powrprof.dll    C:\Windows\System32\powrprof.dll    6.1.7600.16385

Share this post


Link to post
Share on other sites

I have two issues. My first issue is that I am on a college campus so connecting to trackers used to pose a problem for me. I was able to subvert the simple filtering by spoofing a user agent header and connect to both HTTP and HTTPS trackers perfectly fine. To do this, I utilized ProActive Webfilter as a localhost proxy: http://paw-project.sourceforge.net/ Once I had placed the different user agent into ProActive Webfilter, I configured my uTorrent to use a HTTP proxy with address 'localhost' on port '8080' which worked perfectly fine for awhile.

When I switched from 2.0 stable to 2.1 alpha build 18304 I was presented with a new error. The error I was presented with keeps my HTTPS trackers from connecting. The HTTP trackers are working perfectly fine but the HTTPS trackers seem to be the only ones having problems.

The error message is as follows:

Could not establish a secure connection. Error -2146893048

I understand that I could easily switch back to the previous stable version of uTorrent (as the client might be causing the problem) but can anyone explain this error? I've researched the forums and googled around for some answers. The only vague tip that I could figure out is that it DID have to do with HTTPS connections and proxy servers.

Thanks for looking at my issue.

Share this post


Link to post
Share on other sites

Well, uTorrent 2.1 alpha release 18304 runs fine but my campus internet prevents me from properly connecting to the trackers, I receive the 'Connection closed by peer' message without the proxy.

Share this post


Link to post
Share on other sites
Why am I getting double connections from the same peers?

83386341.png

36914077.png

This happened while seeding 2 different torrents on 2 different (private) trackers.

Confirmed again:

31610827.png(2 peers with 2 connections each)

IP addresses blanked out for obvious reasons. Also, as you can see the flags don't match up but they are the same peers. I'm sure of this as I extracted the IPv4 addresses from the IPv6 addresses and they matched up.

Share this post


Link to post
Share on other sites

Possibly 2 computers on the same LAN running uTorrent...which might explain different ports and different percentages complete.

Share this post


Link to post
Share on other sites

Oh, I didn't see it here. Is it in another thread? Thanks!

EDIT: Bug still exists in build 18429. Maybe next build :)

Share this post


Link to post
Share on other sites

I just wanted to add, in regard to post #379, the latest build hasn't addressed it, so hoping that it does get fixed soon.

Thanks.

Share this post


Link to post
Share on other sites

utorrent-2.1-beta-18069.upx is running well on Windows 7 Ultimate x64bit; except for occasional disappearance of the torrent list, I easily get it back by selecting 'Downloading' then 'All'.

The problem now is that subsequent updates could not be installed. I get a message saying that 'utorrent-2.1-beta-18304.upx' or 'utorrent-2.1-beta-18429.upx' is "not a valid Win32 application".

Is there a solution to this problem?

Thank you.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.