Archived

This topic is now archived and is closed to further replies.

Firon

µTorrent 2.2 released

Recommended Posts

No bug. The popup is shown only to allow you to select where to download the torrent to. µTorrent, at that point, hasn't yet actually gotten the torrent metadata that contains the file list, so it can't show it.

Share this post


Link to post
Share on other sites

Greetings!

First of all I'd like to thank everybody who directly or indirectly contributed to this really great software!

I'm using version 2.0.3 (build 20664) and it works great.

The other day I decided to give a try to version 2.2 RC2 (build 22732) and I'd like to point out something I noticed and what is a little disturbing.

----------------------

CPU utilization and loading time

----------------------

----------

ver 2.0.3

----------

while uT is closed to system tray: 0%

while open in window either as active window or not active, just open: 1-2% (constantly)

while selecting a label: 1-3% for a second when a label is selected then drops back

time it takes from starting uT until it's window appears and can be used: less then 30 seconds

----------

ver 2.2 RC2

----------

while uT is closed to system tray: 0%

while open in window either as active window or not active, just open: 15% or a bit above (constantly)

while selecting a label: 20 or even 30% for a second when a label is selected then drops back

time it takes from starting uT until it's window appears and can be used: more then 3 minutes!

----------------------

Conditions are the following:

2000 torrents, none of them ara active, no downloading or uploading in progress

OP.system: Windows XP sp3

CPU: AMD Athlon 64 X2 4200+, 2200 MHz

RAM: 2x1 GB

My guess is that the huge cpu utilization and loading time difference between the 2.0.3 and 2.2 is not intentional so if this is the case and it's possible, please repair it.

Thank You!

Share this post


Link to post
Share on other sites

I dont know if this has been reported before and there was a resolution, but i'm having problems with RSS downloads. It seems that randomly i have some that begin downloads after matches, and some that do not, and have to be manually downloaded.

I use this to download TV shows, and have about 15 different RSS Downloader Favorites. All of them are configured the exact same way, so its not a configuration issue that I can see, as some of them are working.

They all show up in my RSS feed tab

Running 22732 on Windows 7 64bit w/ 4gb ram.

Share this post


Link to post
Share on other sites
ver 2.0.3 ... time it takes from starting uT until it's window appears and can be used: less then 30 seconds

ver 2.2 RC2 ... time it takes from starting uT until it's window appears and can be used: more then 3 minutes!

2000 torrents, none of them ara active, no downloading or uploading in progress

My guess is that the huge cpu utilization and loading time difference between the 2.0.3 and 2.2 is not intentional so if this is the case and it's possible, please repair it.

As far as the load time difference, I believe I can explain what's going on. When this new utorrent starts up, it hits the file system and checks that every single torrents files exist on the drive, regardless of the torrents status, it does not matter if they're stopped, finished, or whatnot. It sparked quite a discussion in the previous beta thread. The result was that it is an intentional change and they will not revert it. So all 2000+ of your torrents are having an existence check on every single file they contain every time utorrent loads. The solution is to either remove all the torrents from utorrent or revert to the previous version.

:D

Share this post


Link to post
Share on other sites

Just got the new version (RC3). Normally I'm not too bothered by these things, but my God, the icons are atrocious! Who makes the decision which icons are used by default?

I know people can change the skin, but I am just baffled by the fact you force people to install the skin changer app. Is it a strategy so users get familiar with installing apps?

Share this post


Link to post
Share on other sites

That's great to see people using a new major version are only concerned about the skin and the icons... :rolleyes:

And if you had read carefully the 1st post, you would have seen it's easy to reskin your client with the default 2.0.4 skin.

Share this post


Link to post
Share on other sites

This old upload chocker where i can manualy assign number of upload slots definatly works better for me. I can get much faster in to positive ratios...

Share this post


Link to post
Share on other sites
That's great to see people using a new major version are only concerned about the skin and the icons... :rolleyes:

And if you had read carefully the 1st post, you would have seen it's easy to reskin your client with the default 2.0.4 skin.

That's not my point. The thing is, the DEFAULT icons should be good. That is, after all, what everyone sees after they install this program. They used to look very nice in v1.8.5 (which I used up till yesterday), so there is no good reason to have poor icons now.

Share this post


Link to post
Share on other sites
That's great to see people using a new major version are only concerned about the skin and the icons... :rolleyes:

And if you had read carefully the 1st post' date=' you would have seen it's easy to reskin your client with the default 2.0.4 skin.[/quote']

That's not my point. The thing is, the DEFAULT icons should be good. That is, after all, what everyone sees after they install this program. They used to look very nice in v1.8.5 (which I used up till yesterday), so there is no good reason to have poor icons now.

+1 ...they used to be fine just a few builds ago.

- Change: always show persistent labels in sidebar

Can this be a user option? {hopes} ...I really liked how it cleaned up the UI...as I don't have all my categories full all of the time.

The last few builds have been working great. Kudos!

Share this post


Link to post
Share on other sites
... I am just baffled by the fact you force people to install the skin changer app. Is it a strategy so users get familiar with installing apps?

I didn't get the skin changer app by default, I just dragged the 2.0.4 btskin file from the 1st post into uTorrent and it did everything itself, no btapp required.

Share this post


Link to post
Share on other sites

Although not recorded as a hang anymore, I am still seeing the long nonresponsive dialog issue when leaving the Setup Guide, even just opening it and Cancelling.

Share this post


Link to post
Share on other sites

Im having difficulty with the latest 2.2 b22982

The usage pattern that stopped working for me is as follows:

1. successfully download file to "new downloads dir" (c:\p2p\in_progress)

2. file is moved from "new downloads dir" to "completed downloads dir" (L:\verify_me)

3. at this point i manually verify the file and move it to it's new home (L:\Library\... )

4. Select Completed | Torrent Name | Advanced | Set Download Location ... (to the new "L" dir)

5. Start

or, if needed

5. Force Re-check, then start

6. File appears in Completed / Seeding list

..And my file is happily being seeded from its new location in the library.

With the latest b22982 version, I'm unable to get my moved files to be recognized as downloaded and available for seeding.

+ uTorrent seems to know where they are .. 'Open Containing Folder' points to the right place

+ Stop | Force Re-Check zips thru it to 100%, then flips to stop (instead of seeding)

+ hitting "start" begins the download all over again.

+ I've verified that the files are indeed intact and not just pre-alloc'd filesystem blobs waiting to be filled in

Anyone else experiencing this.

I'd think you could reproduce it by

1. download torrent

2. wait til it moves to "done" dir

3. manuallly verify it downloaded

4. move file to a different dir

5. reset the torrent file (Advanced | Set download location) to the new file location

6. force recheck if needed

7. start

Lemme know if Im missing something.

Share this post


Link to post
Share on other sites
- Change: Set download location now changes the torrent directory name on a multifile torrent.

Can someone please also revert back to the old 2.0x behaviour for pointing the new location with multi-files' torrent ?

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.