Archived

This topic is now archived and is closed to further replies.

Firon

1.8.1 Release Candidate 1 (build 12549)

Recommended Posts

Under Windows Vista SP1, uTorrent 1.8 build 11813 and 1.8.1 build 11903 stops responding when opening this torrent file:

<munched by admin - see announcement>

Also it caused the followings:

1. The utorrent.exe process cannot be ended

2. Cannot log off user account

3. Cannot shut down Windows

Running as administrator solves part of the problem, but a forced recheck halts halfway (and with the wrong results). Stopping the check and attempting it again causes the symptoms above. It worked perfectly under Windows XP. Is this a file permission problem?

Share this post


Link to post
Share on other sites

Can i just get a mod to clarify where Troubleshooting posts should go, because we have 2 different answers at the moment.

@teohhanhui - Lol, happens to the best of us :P but maybe pay a little more attention? :)

@devs - Good work so far.. I was really confused when i got 3-4 updates on uTorrent in like 4-5 days... Now i know why :) Keep it up :)

Share this post


Link to post
Share on other sites
You can actually force a crash dump to be generated, like so:

In the Windows Task Manager or Process Explorer, look for the [PID] of the µTorrent process. From there, File > Run > ntsd.exe -p [PID] -e [PID] -c ".dump c:\jit.dmp;q"

where [PID] needs to be replaced with the PID of the µTorrent process found in the process list viewer (don't include square brackets). The resulting dump can be found as c:\jit.dmp. Do this when µTorrent hangs, and post the dump.

Under Windows Vista, ntsd.exe no longer comes by default. In this case, users can force a crash dump to be generated via Task Manager's right-click context menu for the µTorrent process, compress it, then upload it.

Upload the dump to mediafire.com or savefile.com.

Personally, I would prefer it if troubleshooting would go into their own threads. It clutters development discussion otherwise.

Share this post


Link to post
Share on other sites

Troubleshooting goes into their own threads in the troubleshooting section of the forums.

We had troubleshooting in the 1.8.0 beta thread and that almost ruined the forum database.

We have declared "never again" for that.

Share this post


Link to post
Share on other sites
Ultima:

...It clutters development discussion otherwise...

meaning ? no comments on features (or missing ones) ? no remarks as to bugs (or suspected ones) ? so what does it mean ? what is this thread for - "a 'thanks-you' thread + changelog & DL link ?? ... ;)

I have a list with bugs/needed-features/links to previous posts/discussions on most-wanted (I think) RSS related issues. Shell I spread it around 3 sections ?

Except for DWK data-base problems - having a large "distribution-list"/subscribers to the a discussion-thread (during over ~half a year+ of development) is a big pro!

well, Ok , in view of this new policy and DB issues, a copy of my RSS bug/features'-list goes to the devs + features request thread... :)

Edit:

Needed RSS DLer features/bugs list is now here: http://forum.utorrent.com/viewtopic.php?pid=352646#p352646

Share this post


Link to post
Share on other sites
1.8 issues only. Unrelated posts will be ignored and deleted.

DO NOT REQUEST FEATURES.

That people chose to ignore this policy in the old thread (and that we failed to properly enforce this policy) doesn't make the policy new. I'm not sure how many times it had to be repeated, too (to you, especially). After giving up, the thread went absolutely out of control, with unrelated conversations mish-mashing all over the place. You were one of the users complaining about how we shouldn't expect users to read the entire thread or be able find every piece of information posted in the thread. Well sure, you were right, but only because so many users decided to disregard the policy, and so the thread exploded.

There were many non-1.8-specific instances of troubleshooting/bug reporting in that old thread, but at the same time, there were instances of troubleshooting for 1.8 in that thread. This did add to the clutter as well, so we're extending the policy to simple troubleshooting. It makes it easier to keep track of specific issues one at a time if discussions get split (I'm all too familiar with this). This thread can still can be used to mention (!= full-on discussion of) bugs discovered in other threads anyway.

It may seem like we're being hardasses, but that's because we've learned from our previous mistake. So let's leave it at that.

Share this post


Link to post
Share on other sites

no problem (though I liked the big thread... and both "issues" and "dev discussions" are vague at best) . Just let me know if you like me to copy/mention bugs from the link above and put them here... I expect some are/might/can be defined as "issues" and are related & going into this 1.8.1 :)

Share this post


Link to post
Share on other sites

The database corruption wasn't really related to the >200 page thread. It was a cockup in one of the database's settings, which is now fixed. So a huge thread won't actually make things go nuts. :P

Share this post


Link to post
Share on other sites

thank you. your comments there will be most welcomed. I can see you never used the RSS filter, so go find out what '*'/wildcard do... (and please don't spam the thread...) ;)

Share this post


Link to post
Share on other sites
What is the peerid for the beta? I've tried adding -UT181B- to my trackers whitelist with no luck :(

Could it be that your tracker is just checking against User-Agent and not peer_id?

User-Agent: uTorrent/181B(11903)

Share this post


Link to post
Share on other sites

After upgrading from 1.8 stable to build 11903 on the "finished" torrents with files previously marked as "Don't Download" become "Normal" reporting something like "Error: missing file".

The sort columns are simply lost after changing view or category.

Thanks, Nam

Share this post


Link to post
Share on other sites
using the latest webui 0.315 and this beta uto build, i'm having an issue with saving webui settings. they just won't stick!

Is this a known issue?

For exemple i chose to have categories not displayed in webui settings, hit apply. all is good until i close IE7 and relaunch webui, settings will be back to default.

Same here.

Share this post


Link to post
Share on other sites

just updated to latest utorrent beta release.(11903)

i have noticed that utorrent is updating the tracker every 35 seconds!! is that normal??? :-/

all my torrents are working OK, tracker is functional and everything is green.

went back to 11813

Share this post


Link to post
Share on other sites

well, mine kept uploading every 35 seconds. this would be terrible for the trackers if lots of user update every half minute.

has it been officially confirmed?

can i send a bug report or something to prove it?

thanks

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.