Archived

This topic is now archived and is closed to further replies.

Directrix

WebUI v0.361 ready for testing

Recommended Posts

I would like to change the status icons on the new webui however the tstatus.png file has the status icons in a vertical configuration whereas the skins files are all in a horizontal config. Where can I get tstatus file in the correct format for webui? cheers

Share this post


Link to post
Share on other sites

Firefox on Mac OSX is a joke... but I cannot confirm. What addons are you using?

Edit: my thought on the naming.. works fine as is, just like the utorrent-help.zip is on the server being updated whenever so you can F1 auto-download it to get the most recent... webui.zip should stay the same name for auto-update purposes... As far as old builds being available, I guess it's prudent to HAVE maybe accessible from TRAC for regression testing?

Share this post


Link to post
Share on other sites

"Show current speed in title bar" is working now but I'd like to suggest a change. It would be a lot more useful if the download and upload speeds were displayed at the start of the title, and in shorter form. That way we could monitor the speed by a quick look at the tab in our browser, and it is the way the option works in µTorrent itself.

For example: Instead of the title being "µTorrent WebUI v0.360 - Download: x.x kB/s | Upload: x.x kB/s" it would be better if it was "D:x.x k U:x.x k - µTorrent WebUI v0.360".

This would make the WebUI near-perfect to me.

Share this post


Link to post
Share on other sites

Found a copy of 0.350 lurking on another box so have gone back to that while waiting for 0.361.

I'll back the idea that earlier version should be made available, keeping the latest incarnation as Webui.zip

and old versions as webui0350.zip etc

Share this post


Link to post
Share on other sites

Virtual Row Threshold isn't working properly for me with 0.360

Utorrent 1.8.1b build 12024 running under WINE, Firefox3 under XP32

E.g. i have 100 torrent, but no matter what i do i can only see the first 50 rows/torrents in the webUI window, but if i hit CTRL+A it says "100 row(s) selected". If i change the Virtual row setting nothing happens, and if i refresh the webUI and then go into the settings it's back to 50 again. All the other settings work.

edit: also tried stable build 11813, but it's exactly the same.

two css errors in the FF error console:

"Unknown property 'zoom'. Declaration dropped."

"Unknown property 'wrap'. Declaration dropped."

both for main.css

unrelated?

Share this post


Link to post
Share on other sites

Well, Chrome seems to be having some minor issues with PNG transparency (see the toolbar buttons) :P

@tmmtmm: Those CSS warnings are unrelated :) Indeed, the setting currently isn't saved properly. It should be fixed in the next update.

@thelittlefire: That is the intent...

Share this post


Link to post
Share on other sites

@ Ultima: Well, you have to have a golden eye to notice that :P. Then a bigger "bug" report: Some of the content haven't been translated yet (into Finnish atleast), like when adding torrents "Torrent file", "Torrent URL" and "Cookies".

Share this post


Link to post
Share on other sites
utorrent version: 1.8.1b build 11903

webui version: 0.360

Just to note, 11903 is a really broken build. Update to the latest one, 12024.

Share this post


Link to post
Share on other sites

Works great on Firefox 3.0.1/Opera 9.60 b10408/Safari 3.1.2/Google Chrome 0.2.149.27 but got stucked at Loading on Internet Explorer 8.0.6001.18241.

uTorrent running on a remote machine.

I'm glad to see this progress :)

Share this post


Link to post
Share on other sites

I have an issue when I rearrange the columns and hide some. The torrents are not shown and I see this error in the browser console (Firefox 3.0.1):

Error: D.childNodes[C].lastChild is null

Source file: http://localhost:7881/gui/stable.js

Line: 1

My column order is:

#, Name, Size, Done, Status, Down Speed, Up Speed, Seeds, Peers, ETA, Uploaded

All the rest are hidden as well as the category box. The issue happens after the first auto refresh.

Share this post


Link to post
Share on other sites

Hah, this was one of several issues we ran into yesterday, and which Directrix fixed (hopefully, anyhow -- I haven't seen it again in internal builds). These random things that we keep finding along the way are what keep delaying the next release. Sorry for the wait time, and please bear with us -- we're trying to polish it up, after all :)

Edit: It's out!

Share this post


Link to post
Share on other sites

I managed to find is not the ordering but hiding columns that breaks the WebUI.

In any case patiently waiting for the update as it seems it's already fixed. :)

Share this post


Link to post
Share on other sites

Just loaded 0.361 and works in IE7 now.

But when hiding columns, it affects the columns to the right of the hide.

ie, hide Labels and the figures from Available move to Peers.

Hide any column and all colums to the right are affected.

(I know what I mean, just cant describe it correctly)

Share this post


Link to post
Share on other sites

This is a message for Photon regarding his messed up webui.

I run utorrent as a service on a win2003 box, today i patched utorrent and the webui to the new version (.361 fixed me up, i was stuck on the loading screen).

I had the same issue as you, turns out i managed not to install over my old utorrent file, the new webui+old utorrent=poop on the screen. What i had to do was

1-stop the service that runs utorrent (this sits on a server, hence i almost never log into it)

2-delete utorrent from the w2003 server (the main .exe that runs utorrent)

3-i deleted the config files for utorrent as-well from the application data folder

4-installed the new utorrent

5-go through the setup in utorrent

6-quit utorrent completely

7-installed the webgui (make sure you're getting .361)

8-start the service that controls utorrent (i never deleted the service since the new utorrent uses the exact same .exe name)

9-i didnt restart my server, but i was able to log into the webgui from a networked box at this point

You may have to skip the steps involving starting/stopping the service, depending on your setup. It's working quite well atm

my setup:

pfsense box-->switch-->server running utorrent as service

to connect remotely:

remote desktop from work-->networked tower--->utorrent webui to the server (my webui isn't on a DMZ or naked to the world. Pretty much only runs internally on my network since port 8080 isnt forwarded by pfsense)

PS: I have no issues running the webui in a remote desktop window

Hope that helps Photon...

PS: Many thanks to the developers for a job well done, utorrent is SOLID!!! I don't get why people constantly complain on here

Share this post


Link to post
Share on other sites

i reverted back to utorrent 1.7.7 and downloaded the webui.1220486382.legacy.zip so do i have to delete webui.zip which i was using for utorrent 1.8 ??

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.