Archived

This topic is now archived and is closed to further replies.

Firon

µTorrent 2.0 beta 17539

Recommended Posts

Hi to all.

I tried this beta version of utorrent and i got a strange problem.

So on i have a laptop and in power options i set to turn off monitor after 10 minuntes of inactivity on the stable version if i not use my pc after 10 minuntes the monitor turn off but on this beta version the monitor remains on. On the both versions i have checked the option Prevent standby if there are active torrents.

Is not a huge problem but sometimes it's annoying specialy when you seed during the night.

Thanks

Share this post


Link to post
Share on other sites

regarding the Transfer Cap:

When set to 1 day, is that a calendar day or the last 24 hours?

Would like the option to set one limit for uploading and one for downloading, and not having to choose either one of them as it's now, as my ISP as one limit for U and one for D. When using the U+D option now, setting the limit to my allowed U and D combined, I could risk exceeding either my allowed U or D as long as the limit is not yet reached and e.g. D speed >> U. To avoid this, setting the U+D limit to either my allowed U or D alone, I'm loosing a lot of potential U or D each day.

There could be a problem with this option that e.g. when allowed U is reached and U getting a cap, that's no good for bittorrent and not beeing able to seed while still D'ing, but having a lot larger D speed than U this issue would rarly occure, and beeing better than the alternative (using U+D option as it's now).

Thanks for a great program!

Share this post


Link to post
Share on other sites

I too have the 'windows ran out of memory. unable to allocate -48 bytes. please close some applications and press ok' . Well. I have the same problem... but the difference is it's a Vista Ultimate X64 SP2.... Everything was fine until yesterday. Then all of a sudden this message started popping up.... i tried visualization, i tried setting the affinity but ...no use, and there is no dump file being created.... neither in the windows crash handler nor in the utorrent errors.... I think i'm going to shift back to 1.8..... for the time being.... Hey I forgot to say, I was using the utorrent 2 something beta.... and then i got an auto update thing from them for a newer beta.... so.... i did update it..... but still i don't think it's got anything to do with the update..... it's just happening at random.... I got 4 gigs of ram so no question of running outta it...... something is not right.... had the problem been there it would have started from the very beginning.... but this is like after a month of using the program without errors.... it just popped up.

Share this post


Link to post
Share on other sites

UPnP is some kind of borked. I've never had any issues prior to 2.0 betas with my router. This build gives me:

[2009-09-04 19:43:47] UPnP: Found location from upnp notify: http://192.168.1.1:80/Public_UPNP_gatedesc.xml

[2009-09-04 19:43:47] UPnP: Discovered host: http://192.168.1.1:80/Public_UPNP_gatedesc.xml

[2009-09-04 19:43:47] UPnP: ERROR mapping TCP port 24897 -> 192.168.1.6:24896. Deleting mapping and trying again: (724) Internal and External port values must be the same

[2009-09-04 19:43:47] UPnP: ERROR removing TCP port 24897: (714) The specified value does not exist in the array

[2009-09-04 19:43:47] UPnP: ERROR mapping TCP port 24897 -> 192.168.1.6:24896: (724) Internal and External port values must be the same

Port is set to 24896 in settings. What is it trying to map 24897 for?

Share this post


Link to post
Share on other sites

Your router really should allow different internal and external ports. It's got a very lame UPnP implementation.

As for why 24896 isn't being mapped, I'm not sure. Have you checked the router for an existing mapping for 24896?

Share this post


Link to post
Share on other sites

I know the router isn't best around. No newsflash for me. It's Netgear WGT624.

And you're right, apparently port 24896 was already mapped.

[2009-09-05 00:04:28] UPnP: ERROR mapping TCP port 24897 -> 192.168.1.6:24896: (724) Internal and External port values must be the same

[2009-09-05 00:24:28] UPnP(XP): TCP port 24896 -> 192.168.1.4:24896 is already mapped. Not re-mapping.

[2009-09-05 00:24:28] UPnP(XP): UDP port 24896 -> 192.168.1.4:24896 is already mapped. Not re-mapping.

[2009-09-05 00:24:41] UPnP: Could not detect external IP on this pass, retrying.

[2009-09-05 00:24:46] UPnP: Could not detect external IP on this pass, retrying.

[2009-09-05 00:24:51] UPnP: Could not detect external IP on this pass, retrying.

[2009-09-05 00:24:56] UPnP: Unable to get external IP with UPnP.

[2009-09-05 00:39:20] Checking for forwarded port

[2009-09-05 00:39:27] Port Forward test complete.

So I guess there isn't much that can be done except for replace the lame router? :)

Share this post


Link to post
Share on other sites

Hm, you have two LAN IPs? Or did yours change halfway through the session?

It looks like the already-mapped port was on 192.168.1.4, but it's trying to map the other port on .6.

Share this post


Link to post
Share on other sites

I am still horrified at the continued use of immature user interference in the 'files' tab, it has been essentially never changed since v1 of utorrent. It is time consuming not to mention essentially useless, perhaps the 'files' tab could get a little make-over in this version 2.0 and by improvement I mean having icons of different file types displayed and sorting by file type and expandable folders and choice of choosing the application to use for opening a file(s). It could be described as a mini windows explorer but only better. I know that most of the utorrent developers would argue why create a explorer in files tab when users can just use the real windows explorer? well this is v2.0 and this is when these things should be implemented, essentially mark this mile stone in utorrent development as the golden build and everyone wants, and besides this type of work is better done sooner then later because it will happen eventually.

Other than that keep up the good work!

Share this post


Link to post
Share on other sites

I fail to see what that has to do with 2.0 specifically. Adding icons or making it a treeview have been requested a million times before -- sure. Doesn't make this the appropriate thread to reiterate. 2.0 is just another number. Some people progress from 1.9 to 1.10, others progress from 1.9 to 2.0. µTorrent just happened to take the latter approach, and not the former -- doesn't mean there needs to be a radical break from old versions.

Share this post


Link to post
Share on other sites

I have been using µTorrent 2.0 beta for a while now with no issues. I have to say i am very impressed with it. Oh and thanks for the update, keep up the great work!

Share this post


Link to post
Share on other sites

in the setup guide the save & close button should always be enabled because i cant get any results from any of the test servers (always getting errors). when i manually choose my connection type i cant apply it because the save & close button is grayed out.

i assume that the save & close button becomes functional only after a successful b/w test, but we should be able to change the connection type without doing the test because its too buggy ATM

Share this post


Link to post
Share on other sites

comments on setup guide(2):

following this feedback: http://forum.utorrent.com/viewtopic.php?pid=423831#p423831

It's MUCH improved now!

1. as unforgiven_sh said, now that we have manual setup - the "save" should be enabled as soon as one picks manual settings

2. the ugly "+" mark better be replaced with the standard "V" check-mark

3. I suggest to add a short description in the "network" test like "testing for proper port forwarding'... which is what it does...

4. and .. control-G - crashes the program ... :P (thank you Switeck...)

and still, from the previous list:

c (redundant download test)

d (pause and not stop downloads)

Nice improvement!

Share this post


Link to post
Share on other sites

hi all,

I would like to know how to see uTP in Advanced as I installed the latest build 16394 and cannot see anything in advanced saying anything similar to uTP .

Share this post


Link to post
Share on other sites

Jsut me or with latest beta, when I try to create a torrent, it crashes, I submitted a bug when it crashed.

Running Win7 64-bit

Share this post


Link to post
Share on other sites
hi all,

I would like to know how to see uTP in Advanced as I installed the latest build 16394 and cannot see anything in advanced saying anything similar to uTP .

bt.transp_disposition in uT Help file (press F1).

Peers using uTP have the flag P in Peers tab.

Share this post


Link to post
Share on other sites
Jsut me or with latest beta, when I try to create a torrent, it crashes, I submitted a bug when it crashed.

Running Win7 64-bit

confirm. But only sometimes. 50/50 percents. Dumps weren't created. I saw only message of the OS "uTorrent is not responding"

Win7 32-bit

Share this post


Link to post
Share on other sites

uTorrent 2.0 build 16394 crashes EVERY time I try to do Speed Guide CTRL+G.

Also, I created a 0-length settings.dat file in the same folder as the uTorrent.exe and tried to launch it. It crashed on launching.

It gets as far as "do you want to make uTorrent the default app for .torrent files Yes/No?"...and waits about 1 second after I hit yes/no to crash.

Next time I launched, I didn't get that message window, but it still crashes a second or 2 after launching.

I tried someone else's settings.dat ...which prevented uTorrent from crashing on start...he had DHT disabled. My old settings.dat which also has DHT disabled doesn't seem to cause a crash... I don't know if that's related though. :(

Running Win 98SE, 512 MB ram, no software firewall or AV...behind a Linksys wrt54gl router, connected to ComCast Cable.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.