Archived

This topic is now archived and is closed to further replies.

Firon

µTorrent 2.0 beta 17539

Recommended Posts

all versions of utorrent 2.0 are putting my internet connection very slow even if i cant upload

for example i have 100 KBs of upload and im uploading only at 20KBs and the internet is very very slow

after i close utorrent connection to internet is normal

this doesnt appear to occur in the utorrent 1.8.4 witch i dont use because, utorrent 2.0 bypasses protocol priorities in download :)

Share this post


Link to post
Share on other sites

uTorrent 2.0.16222 still have upload limit bug...

please fix this... ;)

I set limit for 15KB/s, and uT didnt respect this and upload 2x faster (30KB/s)... this slowing my browsing speed in Firefox, because of eating all upload speed...

bandwidth management set to off/on didnt make any difference...

I use Switeck settings for my 3Mb/256kb (in night I have 12Mb/512kb)

90578891.th.png

Share this post


Link to post
Share on other sites

16222 is misreporting stats, big time.

I'm seeding a small (53.1MB) file. Currently 18 people have completed. Even if I had uploaded ALL the data myself, the total would only be 955.8, yet 16222 is showing 1.31GB & a ratio of 25.359.

Good for my ratio, also a good way to get banned. Guess I'll switch to 1.8.4 until this is corrected.

Also notice that upspeed is jumping wildly, maybe from 40k one second to 60k the next. My connection won't even do 60k.

Share this post


Link to post
Share on other sites

@secret_myth: The dialog appears because you are at risk of crashes if you run NVIDIA NAM and uTorrent at the same time, unless you upgrade NAM to version 73.12. However unfortunately, as you point out, 73.12 has not been released yet. As I understand it should be released fairly soon.

Until version 73.12 is released you should probably just disable NAM if you are going to be running uTorrent. (If this is not possible, NVIDIA tells us it may be sufficient to disable NAM's "FirstPacket" feature until an upgrade to 73.12 becomes possible.)

Share this post


Link to post
Share on other sites

v16222

I hope people at uT have received these reports (uT hung):

hangreport.th.png

I don't know what happened, possibly I was far from my pc at that time (I don't remember).

-------------------------------------------------------------------------------------------------------------------------------------

edit:

I tried setting "TcpAckFrequency" = 1 at XP registry and it did helped A LOT. Now, I'm uploading at "flat" top speed regardless peers latencies (50-300ms) with very much less retransmitted packets.

With this setting, 16222 is working a way better (as far as I'm testing I can say = brilliant!)

-------------------------------------------------------------------------------------------------------------------------------------

Share this post


Link to post
Share on other sites

Hi, more on the "Unable to allocate -48 bytes" error.

oa2fdc.jpg

I'm on a WIN XP SP3 - 2GB RAM

Tried just one torrent, with all these trackers

2m2gbit.jpg

Loading it resulted in an instant error

However, when I removed all of the udp trackers it stopped crashing.

I started removing udp trackers one by one, and I found out that as soon as I add

udp://tracker.torrentbox.com:2710/announce

the problem comes back

So i added that same tracker to another random torrent and voila!, it crashed again.

Something about adding the torrentbox udp tracker may be causing this crash, its up to you devs to find out...

Other users posted screenshots also showing that tracker on the list...

Hope this helps!

EDIT: For other normal users maybe removing this single tracker gets rid of the problem

Share this post


Link to post
Share on other sites

same problem with nachotronics. i follow what he say and delete the torrentbox udp tracker, and it fixed. it was fine yesterday when i start downloading this torrent until 88%, but today when i start utorrent, it crash.

Share this post


Link to post
Share on other sites

please add a EU server to the list, jumping over the sea is kinda bad for speeds :P

a server in the netherlands would be good, its placement will be good for everyone in EU

Share this post


Link to post
Share on other sites

Your own screenshot shows you why. The system cache uses memory because guess what, that's what a system cache is supposed to DO. They use as much free RAM for caching as possible for performance's sake.

Share this post


Link to post
Share on other sites

@ Rafi:

Your MS link is correct.

Default value is 2 and is not shown.

To change it you have to create one (DWORD), on that key [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\<Interface GUID>]

IF it doesn't work, see http://support.microsoft.com/kb/815230/ b/c you have to do some update. I have XP-PRO-SP3 working here.

BTW, I don't know if it's necessary but I have the same string on [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters]

ok?

Share this post


Link to post
Share on other sites

Honestly, you shouldn't really be enabling that. Having memory used for caching is a good thing...

Share this post


Link to post
Share on other sites

#Firon

> Honestly, you shouldn't really be enabling that. Having memory used for caching is a good thing...

No/ When memory ends - windows work very slow

Share this post


Link to post
Share on other sites

I have a speed related issue with the latest release (Actually since the 2.0 Beta and on)

I'm running a Linksys WRT54GL and using DD-WRT v23 SP2 on it. I've increased my maximum ports in the router to 4096, And changed my timeouts to 90 seconds. I'm also using the conservative Utorrent settings as linked earlier. Finally, I've patched my tcpip.sys to allow 50 connections.

The thing is, my download and upload speed both seem to be on a roller coaster in terms of speed. I'll typically start Utorrent and have had speeds as high as 1.1 MB/Sec. However after about 5 minutes the speed drops dramatically. Then, as it's nearing a crawl (around 20-30 kb/s) it starts to rise again, slowly. It usually makes it up to about 100 kb/s before it flat lines again. Rinse and repeat, often. I've included an image of my speed graph to demonstrate. Any ideas why this is?

speedgraph.th.jpg

Update:

Tried out changing bt.transp_disposition to 5 rather than the default 15 - I'm seeing dramatic speed increases, back up in the 1 MB/S territory.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.