Archived

This topic is now archived and is closed to further replies.

Firon

µTorrent 3.0 (32-bit) Stable Release

Recommended Posts

Even if you want all torrents to go into the same folder, you have to touch each one. IMHO not very user-friendly.
I agree that moving by "change location" is new and might be improved.

Let's hope they'll improve it. Like with "move/yes to all" option...

Share this post


Link to post
Share on other sites

uT build 25395 x32, Win XP SP3. I have noticed many red torrents with error in status column: "An operation on a socket could not be performed because the system lacked sufficient buffer space or because a queue was full." uT logs shows next:

[2011-06-20 03:48:00]  Error: data.mkv - Not enough quota is available to process this command. [2011-06-20 03:49:05]  File failed verification: C:\Program Files\uTorrent\resume.dat.new[2011-06-20 03:49:05]  Unable to save the resume file. Another program might have the file open, or the disk is full.[2011-06-20 03:49:24]  Error opening "k:\tor\data2\data2.mkv": [2011-06-20 03:49:24]  Error: data2 - Not enough quota is available to process this command. [2011-06-20 03:51:06]  Failed file save: C:\Program Files\uTorrent\resume.dat.new[2011-06-20 03:51:06]  Unable to save the resume file. Another program might have the file open, or the disk is full.[2011-06-20 03:53:07]  File failed verification: C:\Program Files\uTorrent\resume.dat.new[2011-06-20 03:53:07]  Unable to save the resume file. Another program might have the file open, or the disk is full.[2011-06-20 03:55:08]  Failed file save: C:\Program Files\uTorrent\resume.dat.new[2011-06-20 03:55:08]  Unable to save the resume file. Another program might have the file open, or the disk is full.[2011-06-20 03:57:09]  Failed file save: C:\Program Files\uTorrent\resume.dat.new[2011-06-20 03:57:09]  Unable to save the resume file. Another program might have the file open, or the disk is full.[2011-06-20 03:59:10]  File failed verification: C:\Program Files\uTorrent\resume.dat.new[2011-06-20 03:59:10]  Unable to save the resume file. Another program might have the file open, or the disk is full.[2011-06-20 04:01:11]  Failed file save: C:\Program Files\uTorrent\resume.dat.new[2011-06-20 04:01:11]  Unable to save the resume file. Another program might have the file open, or the disk is full.[2011-06-20 04:03:12]  Failed file save: C:\Program Files\uTorrent\resume.dat.new[2011-06-20 04:03:12]  Unable to save the resume file. Another program might have the file open, or the disk is full.[2011-06-20 04:05:13]  Unable to save the resume file. Another program might have the file open, or the disk is full.[2011-06-20 04:06:11]  Failed file save: C:\Program Files\uTorrent\settings.dat.new[2011-06-20 04:07:14]  File failed verification: C:\Program Files\uTorrent\resume.dat.new[2011-06-20 04:07:14]  Unable to save the resume file. Another program might have the file open, or the disk is full.[2011-06-20 04:09:15]  Failed file save: C:\Program Files\uTorrent\resume.dat.new

Disks C and K are not full. Each has more than 16 GB of free space. resume.dat.new and settings.dat.new are absent in uT folder. resume.dat and settings.dat exist and they are being updated normally - their modification data is being changed all the time. Using Unlocker on these files shows, that these files are not locked by any program. Also those log records repeat constantly. uT is uploading good torrents (without that error) with speed around 5% from maximum. uT doesn't use uTP. Its cache is 32 MB. Using task manager I see that its virtual memory usage is around 91 MB and I have plenty of free memory. Average number of active connections is ~40.

Googling I can assume that operation system is running out of non-paged pool. Windows event viewer doesn't tell any error. I do not use PAE nor /3GB switch in boot.ini.

Restarting uT and starting error torrents makes uT work normally (no error message about dat files in log). I didn't restart OS. It makes me think that bug is inside uT. It is first time I see this issue.

Share this post


Link to post
Share on other sites
It's not the speed itself. It's the handling. If you select several torrents you still have to do all the clicking for each torrent. Meaning:

- select X torrents

- right-click one of the selected torrents and select "change location"

- now it starts:

- for single-file downloads, go up at least one folder and then open another folder and click OK (at least three clicks); for folders at least two clicks

- repeat X-1 times until you're done :(

Even if you want all torrents to go into the same folder, you have to touch each one. IMHO not very user-friendly.

I agree 100%. It's better than it used to be, but this last bug is still preventing me from using it. Moving 10 or more torrents takes an enormous amount of effort.

Share this post


Link to post
Share on other sites

It is first time I see this issue.

Check task manager, if you can see more than one utorrent.exe process running .

Share this post


Link to post
Share on other sites
Check task manager, if you can see more than one utorrent.exe process running .

Unfortunately I didn't check it that time. After that problem was noticed, I investigated what I could, then manually quit uT and ran it again. It worked correctly for some time (I guess 20 minutes) and then quit itself without crashing report. There also was dead uT icon in the tray, which disappeared when I hovered over it. Then I decided that it might be OS issue after all (system uptime was around 6 days) and I restarted OS. I haven't noticed this issue since then.

It is a bit pity, that uT doesn't remember log file, which is selected in "Log to file..." after restarting uT. It is not fun to set it manually every time I start uT. If it would remember log file, then I could provide you log for that situation, when uT decided to quit itself.

Share this post


Link to post
Share on other sites
Check task manager' date=' if you can see more than one utorrent.exe process running .[/quote']

It is a bit pity, that uT doesn't remember log file, which is selected in "Log to file..." after restarting uT. It is not fun to set it manually every time I start uT. If it would remember log file, then I could provide you log for that situation, when uT decided to quit itself.

It's a good idea - to be able to open a log file as either new or appended and always open this log file on startup in "append" state if the user option it.

Share this post


Link to post
Share on other sites
Even if you want all torrents to go into the same folder' date=' you have to touch each one. IMHO not very user-friendly.[/quote']
I agree that moving by "change location" is new and might be improved.

Let's hope they'll improve it. Like with "move/yes to all" option...

Yeah, but unless the other problem which I'm experiencing is fixed, any improvements will be useless for me. :rolleyes:

Share this post


Link to post
Share on other sites

Hi, I think this is a very minor problem, but nevertheless here it is:

Even though I've set utorrent to start minimized on [Windows] startup, it still show the window on system startup. Also, it always shows up in a restored down window, but the size of the window is larger than a maximized window, i.e., it's like a maximized window but the top edge of the window is out of the monitor.

I think it started on RC4 or RC5, I'm not sure because at that time I thought it was only a minor problem, but it got annoying. I'm on RC7 now (build 25400). Anybody else got this problem, or is it just me? Thanks.

Share this post


Link to post
Share on other sites

Bugs are still there in RC7:

- "Remove..", "Remove and delete .torrent", "Remove and delete .torrent + Data", "Remove and delete Data" - now is not working in RC7

- "Move to trash if passible" - This option is ignored. Files don't move to trash

- CPU usage 25-40% (when net.low_cpu=false)

Share this post


Link to post
Share on other sites

Bug in RC7: after closing of the program it continues to hang in processes, but on a hard disk does not render loading. It takes place not always, but enough often.

Windows 7 SP1 64 bit

I confirm bugs, which w000t specified on.

P.S. I am sorry for bad English, I am Russian. :)

Share this post


Link to post
Share on other sites

@BotNet :

Do you close it with file->exit ? Can you show here your preference->UI settings ? Make sure you do not have "close-to-tray" checked + " the always show tray ocon" uncheck + use "close/F4. They have a bug with this settings-combination.

Share this post


Link to post
Share on other sites
@BotNet :

Do you close it with file->exit ?

Right mouse button on a tray->exit.

@BotNet :

Can you show here your preference->UI settings ?

85115efe043d65bb22e968a8ea0e8f84.png

@BotNet :

Make sure you do not have "close-to-tray" checked + " the always show tray ocon" uncheck + use "close/F4. They have a bug with this settings-combination.

Here what is the matter. Understood. Strange. Noticed such only on RC7. On RC6 all was normal.

Share this post


Link to post
Share on other sites

Just curious, it's fixed maybe in RC8 ?

If not, you really should fix it before releasing a stable version.

CRITICAL BUG in µTorrent 3.0.25327

It delete permanently torrent with all files from disc, instead of using trash, even if gui.default.del_action and gui.delete.to_trash have default values (0 and true)

P.S. Help file didn't start... probably download issue

EDIT:

I want to add that all that's remains is only torrent file in uTorrent in Roaming folder, which should be also moved to trash

Share this post


Link to post
Share on other sites

I have noticed that toolbar icons in new uTorrent 3.0 have been refined and they are not so flat anymore like in 2.2.

Could you apply this art style also on main application icon? Current default icon is too flat and little more depth and gradients would be nice..

Share this post


Link to post
Share on other sites

The UI opens fully and does not close to the tray unless you manually close it. Version 2.2.1 does not have this flaw.

Share this post


Link to post
Share on other sites
Because it's best to wait a while, see it's not broken... Better be safe than sorry...

In other words - Firon probably forgets... :P

Naw...actually Firon is just on a well-earned vacation and I (his stand-in) am not nearly as thorough as he is. But he will be back soon to make all okay again. :)

Share this post


Link to post
Share on other sites
The UI opens fully and does not close to the tray unless you manually close it. Version 2.2.1 does not have this flaw.

It appears to work fine. In your "Preferences->UI Settings" make sure you are setting "Minimize to tray" and "Close to tray" to meet your requirements. The "X" button at the top right of the ut window performs "Close" and the button one over, on its left, which looks like a simple bar performs the 'minimize' operation.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.